lkml.org 
[lkml]   [2020]   [Jun]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/5] devres: provide and use devm_krealloc()
Date
From: Bartosz Golaszewski <bgolaszewski@baylibre.com>

Regular krealloc() obviously can't work with managed memory. This series
implements devm_krealloc() and adds the first user with hope that this
helper will be adopted by other drivers currently using non-managed
krealloc().

Some cosmetic changes to the code modified by main patches are included.

Bartosz Golaszewski (5):
devres: remove stray space from devm_kmalloc() definition
devres: move the size check from alloc_dr() into a separate function
device: remove 'extern' attribute from function prototypes in device.h
devres: provide devm_krealloc()
hwmon: pmbus: use more devres helpers

.../driver-api/driver-model/devres.rst | 1 +
drivers/base/devres.c | 58 ++++-
drivers/hwmon/pmbus/pmbus_core.c | 27 +--
include/linux/device.h | 225 +++++++++---------
4 files changed, 173 insertions(+), 138 deletions(-)

--
2.26.1

\
 
 \ /
  Last update: 2020-06-26 18:56    [W:0.100 / U:0.264 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site