lkml.org 
[lkml]   [2020]   [Jun]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
SubjectRe: [PATCH v5 3/3] media: vimc: Add a control to display info on test image
From
Date
Hi Kaaira,

On 24/06/2020 14:51, Hans Verkuil wrote:
> On 24/06/2020 15:43, Kaaira Gupta wrote:
>> Add a control in VIMC to display information such as the correct order of
>> colors for a given test pattern, brightness, hue, saturation, contrast,
>> width and height at sensor over test image.
>>
>> Signed-off-by: Kaaira Gupta <kgupta@es.iitr.ac.in>
>> ---
>> drivers/media/test-drivers/vimc/Kconfig | 2 +
>> drivers/media/test-drivers/vimc/vimc-common.h | 1 +
>> drivers/media/test-drivers/vimc/vimc-core.c | 10 ++++
>> drivers/media/test-drivers/vimc/vimc-sensor.c | 57 +++++++++++++++++++
>> 4 files changed, 70 insertions(+)
>>
>> diff --git a/drivers/media/test-drivers/vimc/Kconfig b/drivers/media/test-drivers/vimc/Kconfig
>> index 4068a67585f9..da4b2ad6e40c 100644
>> --- a/drivers/media/test-drivers/vimc/Kconfig
>> +++ b/drivers/media/test-drivers/vimc/Kconfig
>> @@ -2,6 +2,8 @@
>> config VIDEO_VIMC
>> tristate "Virtual Media Controller Driver (VIMC)"
>> depends on VIDEO_DEV && VIDEO_V4L2
>> + select FONT_SUPPORT
>> + select FONT_8x16
>> select MEDIA_CONTROLLER
>> select VIDEO_V4L2_SUBDEV_API
>> select VIDEOBUF2_VMALLOC
>> diff --git a/drivers/media/test-drivers/vimc/vimc-common.h b/drivers/media/test-drivers/vimc/vimc-common.h
>> index ae163dec2459..afda52253402 100644
>> --- a/drivers/media/test-drivers/vimc/vimc-common.h
>> +++ b/drivers/media/test-drivers/vimc/vimc-common.h
>> @@ -20,6 +20,7 @@
>> #define VIMC_CID_VIMC_CLASS (0x00f00000 | 1)
>> #define VIMC_CID_TEST_PATTERN (VIMC_CID_VIMC_BASE + 0)
>> #define VIMC_CID_MEAN_WIN_SIZE (VIMC_CID_VIMC_BASE + 1)
>> +#define VIMC_CID_SHOW_INFO (VIMC_CID_VIMC_BASE + 2)
>>
>> #define VIMC_FRAME_MAX_WIDTH 4096
>> #define VIMC_FRAME_MAX_HEIGHT 2160
>> diff --git a/drivers/media/test-drivers/vimc/vimc-core.c b/drivers/media/test-drivers/vimc/vimc-core.c
>> index 11210aaa2551..461320ae965c 100644
>> --- a/drivers/media/test-drivers/vimc/vimc-core.c
>> +++ b/drivers/media/test-drivers/vimc/vimc-core.c
>> @@ -5,10 +5,12 @@
>> * Copyright (C) 2015-2017 Helen Koike <helen.fornazier@gmail.com>
>> */
>>
>> +#include <linux/font.h>
>> #include <linux/init.h>
>> #include <linux/module.h>
>> #include <linux/platform_device.h>
>> #include <media/media-device.h>
>> +#include <media/tpg/v4l2-tpg.h>
>> #include <media/v4l2-device.h>
>>
>> #include "vimc-common.h"
>> @@ -263,6 +265,7 @@ static int vimc_register_devices(struct vimc_device *vimc)
>>
>> static int vimc_probe(struct platform_device *pdev)
>> {
>> + const struct font_desc *font = find_font("VGA8x16");
>> struct vimc_device *vimc;
>> int ret;
>>
>> @@ -272,6 +275,13 @@ static int vimc_probe(struct platform_device *pdev)
>> if (!vimc)
>> return -ENOMEM;
>>
>> + if (!font) {
>> + dev_err(&pdev->dev, "vimc: could not find font\n");
>> + return -ENODEV;
>> + }
>> +
>> + tpg_set_font(font->data);
>> +
>> vimc->pipe_cfg = &pipe_cfg;
>>
>> /* Link the media device within the v4l2_device */
>> diff --git a/drivers/media/test-drivers/vimc/vimc-sensor.c b/drivers/media/test-drivers/vimc/vimc-sensor.c
>> index a2f09ac9a360..d776fdcdc3bf 100644
>> --- a/drivers/media/test-drivers/vimc/vimc-sensor.c
>> +++ b/drivers/media/test-drivers/vimc/vimc-sensor.c
>> @@ -19,6 +19,8 @@ struct vimc_sen_device {
>> struct v4l2_subdev sd;
>> struct tpg_data tpg;
>> u8 *frame;
>> + unsigned show_info;

It's better to declare a 'type' rather than just unsigned.
i.e.
unsigned int
unsigned long




>> + unsigned ns;
>
> That name is a bit vague. How about 'start_stream_ts' (ts == timestamp)?
>
> Note also that ktime_get_ns() returns a u64, not an unsigned.
>
> Regards,
>
> Hans
>
>> /* The active format */
>> struct v4l2_mbus_framefmt mbus_format;
>> struct v4l2_ctrl_handler hdl;
>> @@ -185,10 +187,43 @@ static const struct v4l2_subdev_pad_ops vimc_sen_pad_ops = {
>> static void *vimc_sen_process_frame(struct vimc_ent_device *ved,
>> const void *sink_frame)
>> {
>> + u8 *basep[TPG_MAX_PLANES][2];
>> + char str[100];
>> + int line = 1;
>> struct vimc_sen_device *vsen = container_of(ved, struct vimc_sen_device,
>> ved);
>>
>> tpg_fill_plane_buffer(&vsen->tpg, 0, 0, vsen->frame);
>> + tpg_calc_text_basep(&vsen->tpg, basep, 0, vsen->frame);
>> +
>> + if (vsen->show_info <= 1) {

I would suggest creating an enum of the possible values so that you can
do a switch statement here, otherwise a reader of the code will be
thinking "What is 1 refering to?"


At least then you could do:

switch(vsen->show_info) {
VSEN_SHOW_ALL:
... do all stuff ..
/* fallthrough */
VSEN_SHOW_COUNTERS:
... do just the counters ...
/* fallthrough */ (or break;)
VSEN_SHOW_NONE:
default:
break;
}


Looking at vivid, I can see that the use of the numbers came from there,
but it would be nice to try to improve readability some how...


>> + unsigned ms;
>> +
>> + ms = (ktime_get_ns() - vsen->ns) / 1000000;
>> + snprintf(str, sizeof(str), "%02d:%02d:%02d:%03d",
>> + (ms / (60 * 60 * 1000)) % 24,
>> + (ms / (60 * 1000)) % 60,
>> + (ms / 1000) % 60,
>> + ms % 1000);
>> + tpg_gen_text(&vsen->tpg, basep, line++ * 16, 16, str);

you've used "line++ * 16" where vivid seems to always use line++ *
line_height.

Perhaps vivid can customise the value there with a control, but even if
not, it would be better to put a
const unsigned int line_height = 16;

at the top of the function so it's clear what that parameter does.

>> + }
>> +
>> + if (vsen->show_info == 0) {
>> + const char *order = tpg_g_color_order(&vsen->tpg);
>> +
>> + tpg_gen_text(&vsen->tpg, basep, line++ * 16, 16, order);
>> + snprintf(str, sizeof(str),
>> + "brightness %3d, contrast %3d, saturation %3d, hue %d ",
>> + vsen->tpg.brightness,
>> + vsen->tpg.contrast,
>> + vsen->tpg.saturation,
>> + vsen->tpg.hue);
>> + tpg_gen_text(&vsen->tpg, basep, line++ * 16, 16, str);
>> + snprintf(str, sizeof(str), "sensor size: %dx%d",
>> + vsen->mbus_format.width, vsen->mbus_format.height);
>> + tpg_gen_text(&vsen->tpg, basep, line++ * 16, 16, str);
>> + }
>> +
>> return vsen->frame;
>> }
>>
>> @@ -201,6 +236,8 @@ static int vimc_sen_s_stream(struct v4l2_subdev *sd, int enable)
>> const struct vimc_pix_map *vpix;
>> unsigned int frame_size;
>>
>> + vsen->ns = ktime_get_ns();
>> +
>> /* Calculate the frame size */
>> vpix = vimc_pix_map_by_code(vsen->mbus_format.code);
>> frame_size = vsen->mbus_format.width * vpix->bpp *
>> @@ -269,6 +306,9 @@ static int vimc_sen_s_ctrl(struct v4l2_ctrl *ctrl)
>> case V4L2_CID_SATURATION:
>> tpg_s_saturation(&vsen->tpg, ctrl->val);
>> break;
>> + case VIMC_CID_SHOW_INFO:
>> + vsen->show_info = ctrl->val;
>> + break;
>> default:
>> return -EINVAL;
>> }
>> @@ -307,6 +347,22 @@ static const struct v4l2_ctrl_config vimc_sen_ctrl_test_pattern = {
>> .qmenu = tpg_pattern_strings,
>> };
>>
>> +static const char * const vimc_ctrl_show_info_strings[] = {
>> + "All",
>> + "Counters Only",
>> + "None",
>> + NULL,
>> +};
>> +
>> +static const struct v4l2_ctrl_config vimc_sen_ctrl_show_info = {
>> + .ops = &vimc_sen_ctrl_ops,
>> + .id = VIMC_CID_SHOW_INFO,
>> + .name = "Show Information",
>> + .type = V4L2_CTRL_TYPE_MENU,
>> + .max = ARRAY_SIZE(vimc_ctrl_show_info_strings) - 2,
>> + .qmenu = vimc_ctrl_show_info_strings,
>> +};
>> +
>> static struct vimc_ent_device *vimc_sen_add(struct vimc_device *vimc,
>> const char *vcfg_name)
>> {
>> @@ -323,6 +379,7 @@ static struct vimc_ent_device *vimc_sen_add(struct vimc_device *vimc,
>>
>> v4l2_ctrl_new_custom(&vsen->hdl, &vimc_sen_ctrl_class, NULL);
>> v4l2_ctrl_new_custom(&vsen->hdl, &vimc_sen_ctrl_test_pattern, NULL);
>> + v4l2_ctrl_new_custom(&vsen->hdl, &vimc_sen_ctrl_show_info, NULL);
>> v4l2_ctrl_new_std(&vsen->hdl, &vimc_sen_ctrl_ops,
>> V4L2_CID_VFLIP, 0, 1, 1, 0);
>> v4l2_ctrl_new_std(&vsen->hdl, &vimc_sen_ctrl_ops,
>>
>

--
Regards
--
Kieran

\
 
 \ /
  Last update: 2020-06-25 16:54    [W:0.070 / U:1.104 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site