lkml.org 
[lkml]   [2020]   [Jun]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 6/6] kernel: add a kernel_wait helper
On Sat, Jun 20, 2020 at 08:35:38AM +0200, Christoph Hellwig wrote:
> On Fri, Jun 19, 2020 at 09:17:00PM +0000, Luis Chamberlain wrote:
> > On Thu, Jun 18, 2020 at 04:46:27PM +0200, Christoph Hellwig wrote:
> > > --- a/kernel/exit.c
> > > +++ b/kernel/exit.c
> > > @@ -1626,6 +1626,22 @@ long kernel_wait4(pid_t upid, int __user *stat_addr, int options,
> > > return ret;
> > > }
> > >
> > > +int kernel_wait(pid_t pid, int *stat)
> > > +{
> > > + struct wait_opts wo = {
> > > + .wo_type = PIDTYPE_PID,
> > > + .wo_pid = find_get_pid(pid),
> > > + .wo_flags = WEXITED,
> > > + };
> > > + int ret;
> > > +
> > > + ret = do_wait(&wo);
> > > + if (ret > 0 && wo.wo_stat)
> > > + *stat = wo.wo_stat;
> >
> > Since all we care about is WEXITED, that could be simplified
> > to something like this:
> >
> > if (ret > 0 && KWIFEXITED(wo.wo_stat)
> > *stat = KWEXITSTATUS(wo.wo_stat)
> >
> > Otherwise callers have to use W*() wrappers.
> >
> > > + put_pid(wo.wo_pid);
> > > + return ret;
> > > +}
> >
> > Then we don't get *any* in-kernel code dealing with the W*() crap.
> > I just unwrapped this for the umh [0], given that otherwise we'd
> > have to use KW*() callers elsewhere. Doing it upshot one level
> > further would be even better.
> >
> > [0] https://lkml.kernel.org/r/20200610154923.27510-1-mcgrof@kernel.org
> Do you just want to pick this patch up, add your suggested bits and
> add it to the beginning of your series? That should clean the whole
> thing up a bit. Nothing else in this series depends on the patch.

Sure but let's wait to hear from the NFS folks.

I'm waiting to hear from NFS folks if the one place where the UMH is
fixed for the error code (on fs/nfsd/nfs4recover.c we never were
disabling the upcall as the error code of -ENOENT or -EACCES was *never*
properly checked for) to see how critical that was. If it can help
stable kernels the fix can go in as I proposed, followed by this patch
to further take the KWEXITSTATUS() up further, and ensure we *never*
deal with this in-kernel. If its not a fix stable kernels should care
for what you suggest of taking this patch first would be best and I'd be
happy to do that.

Luis

\
 
 \ /
  Last update: 2020-06-20 19:02    [W:0.045 / U:0.520 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site