lkml.org 
[lkml]   [2020]   [Jun]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] kernel/trace: Remove function callback casts
On Mon, 15 Jun 2020 16:17:38 -0400
Steven Rostedt <rostedt@goodmis.org> wrote:

> On Sun, 14 Jun 2020 09:01:54 +0200
> Oscar Carter <oscar.carter@gmx.com> wrote:
>
> > In an effort to enable -Wcast-function-type in the top-level Makefile to
> > support Control Flow Integrity builds, remove all the function callback
> > casts.
> >
> > To do this, use the ftrace_ops_list_func function as a wrapper when the
> > arch not supports ftrace ops instead of the use of a function cast.
> >
>
> We need more tricker than this.
>
> > Signed-off-by: Oscar Carter <oscar.carter@gmx.com>
> > ---
> > kernel/trace/ftrace.c | 11 ++++++++---
> > 1 file changed, 8 insertions(+), 3 deletions(-)
> >
> > diff --git a/kernel/trace/ftrace.c b/kernel/trace/ftrace.c
> > index c163c3531faf..ed1efc0e3a25 100644
> > --- a/kernel/trace/ftrace.c
> > +++ b/kernel/trace/ftrace.c
> > @@ -119,13 +119,12 @@ struct ftrace_ops __rcu *ftrace_ops_list __read_mostly = &ftrace_list_end;
> > ftrace_func_t ftrace_trace_function __read_mostly = ftrace_stub;
> > struct ftrace_ops global_ops;
> >
> > -#if ARCH_SUPPORTS_FTRACE_OPS
> > static void ftrace_ops_list_func(unsigned long ip, unsigned long parent_ip,
> > struct ftrace_ops *op, struct pt_regs *regs);
> > -#else
> > +
> > +#if !ARCH_SUPPORTS_FTRACE_OPS
> > /* See comment below, where ftrace_ops_list_func is defined */
> > static void ftrace_ops_no_ops(unsigned long ip, unsigned long parent_ip);
> > -#define ftrace_ops_list_func ((ftrace_func_t)ftrace_ops_no_ops)
>
> The reason for the typecast is because this gets called from asm with only two parameters.

[ Some how hit a short cut key that sent this before I was finished! :-p ]

As I was saying. This typecast is being paranoid, as archs will call
the ftrace_ops_list_func directly, and only pass in two parameters.

Now one way around this is to instead of having the typecast, I could
use linker magic to create another function that I can define without
the typecast to get the same effect. Similar to what I did in commit:

46f9469247c6f ("ftrace: Rename ftrace_graph_stub to ftrace_stub_graph")

-- Steve



>
> > #endif
> >
> > static inline void ftrace_ops_init(struct ftrace_ops *ops)
> > @@ -6860,6 +6859,12 @@ static void ftrace_ops_list_func(unsigned long ip, unsigned long parent_ip,
> > }
> > NOKPROBE_SYMBOL(ftrace_ops_list_func);
> > #else
> > +static void ftrace_ops_list_func(unsigned long ip, unsigned long parent_ip,
> > + struct ftrace_ops *op, struct pt_regs *regs)
> > +{
> > + ftrace_ops_no_ops(ip, parent_ip);
> > +}
> > +
> > static void ftrace_ops_no_ops(unsigned long ip, unsigned long parent_ip)
> > {
> > __ftrace_ops_list_func(ip, parent_ip, NULL, NULL);
> > --
> > 2.20.1
>

\
 
 \ /
  Last update: 2020-06-15 22:23    [W:0.074 / U:0.464 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site