lkml.org 
[lkml]   [2020]   [May]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH rdma-next 00/10] Various clean ups to ib_cm
Date
From: Leon Romanovsky <leonro@mellanox.com>

From Jason,

These are intended to be no-functional change edits that tidy up the
code flow or coding style.

Thanks

Danit Goldberg (1):
RDMA/cm: Remove unused store to ret in cm_rej_handler

Jason Gunthorpe (9):
RDMA/addr: Mark addr_resolve as might_sleep()
RDMA/cm: Remove return code from add_cm_id_to_port_list
RDMA/cm: Pull duplicated code into cm_queue_work_unlock()
RDMA/cm: Pass the cm_id_private into cm_cleanup_timewait
RDMA/cm: Add a note explaining how the timewait is eventually freed
RDMA/cm: Make find_remote_id() return a cm_id_private
RDMA/cm: Remove the cm_free_id() wrapper function
RDMA/cm: Remove needless cm_id variable
RDMA/cm: Increment the refcount inside cm_find_listen()

drivers/infiniband/core/addr.c | 4 +
drivers/infiniband/core/cm.c | 239 +++++++++++----------------------
2 files changed, 85 insertions(+), 158 deletions(-)

--
2.26.2

\
 
 \ /
  Last update: 2020-05-06 09:48    [W:0.032 / U:0.384 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site