lkml.org 
[lkml]   [2020]   [May]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH 11/15] staging: wfx: prefer ARRAY_SIZE instead of a magic number
Date
From: Jérôme Pouiller <jerome.pouiller@silabs.com>

When possible, we prefer to use the macro ARRAY_SIZE rather than hard
coding the number of elements.

Signed-off-by: Jérôme Pouiller <jerome.pouiller@silabs.com>
---
drivers/staging/wfx/data_tx.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/staging/wfx/data_tx.c b/drivers/staging/wfx/data_tx.c
index 30aa8c267cd0..83a9256f09bf 100644
--- a/drivers/staging/wfx/data_tx.c
+++ b/drivers/staging/wfx/data_tx.c
@@ -166,13 +166,13 @@ static int wfx_tx_policy_upload(struct wfx_vif *wvif)

do {
spin_lock_bh(&wvif->tx_policy_cache.lock);
- for (i = 0; i < HIF_TX_RETRY_POLICY_MAX; ++i) {
+ for (i = 0; i < ARRAY_SIZE(wvif->tx_policy_cache.cache); ++i) {
is_used = memzcmp(policies[i].rates,
sizeof(policies[i].rates));
if (!policies[i].uploaded && is_used)
break;
}
- if (i < HIF_TX_RETRY_POLICY_MAX) {
+ if (i < ARRAY_SIZE(wvif->tx_policy_cache.cache)) {
policies[i].uploaded = true;
memcpy(tmp_rates, policies[i].rates, sizeof(tmp_rates));
spin_unlock_bh(&wvif->tx_policy_cache.lock);
@@ -180,7 +180,7 @@ static int wfx_tx_policy_upload(struct wfx_vif *wvif)
} else {
spin_unlock_bh(&wvif->tx_policy_cache.lock);
}
- } while (i < HIF_TX_RETRY_POLICY_MAX);
+ } while (i < ARRAY_SIZE(wvif->tx_policy_cache.cache));
return 0;
}

@@ -204,7 +204,7 @@ void wfx_tx_policy_init(struct wfx_vif *wvif)
INIT_LIST_HEAD(&cache->used);
INIT_LIST_HEAD(&cache->free);

- for (i = 0; i < HIF_TX_RETRY_POLICY_MAX; ++i)
+ for (i = 0; i < ARRAY_SIZE(cache->cache); ++i)
list_add(&cache->cache[i].link, &cache->free);
}

--
2.26.1
\
 
 \ /
  Last update: 2020-05-05 14:40    [W:2.018 / U:0.348 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site