lkml.org 
[lkml]   [2020]   [May]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[RFC][PATCH 0/3] objtool: Support implicit addend relocations
Date
Future tools that use objtool to process ELF object files may require
reading or even modifying relocations with implicit addends. This
series cleans up the naming of the relocation struct in objtool,
variable names, and function names to be consistent with a more
generic use rather than being specific to those applying explicit
addends.

From there we switch to the specification compliant method of
finding the section the relocations apply to and fall back to the
old naming-heuristic basis if that's not available.

Finally, add support for implicit addends. Note that we don't
completely convert the orc tools to work with both kinds of
relocations. I'm hoping to get feedback on whether it makes more
sense to convert it or leave it as-is.

Matt Helsley (3):
objtool: Rename rela to reloc
objtool: Find relocation base section using sh_info
objtool: Add support for relocations without addends

tools/objtool/arch.h | 2 +-
tools/objtool/arch/x86/decode.c | 2 +-
tools/objtool/check.c | 196 +++++++++++++-------------
tools/objtool/check.h | 2 +-
tools/objtool/elf.c | 237 +++++++++++++++++++++-----------
tools/objtool/elf.h | 27 ++--
tools/objtool/orc_gen.c | 46 +++----
tools/objtool/special.c | 28 ++--
8 files changed, 311 insertions(+), 229 deletions(-)


base-commit: 7c0577f4e609f7278ebd6d21e2de82b42f110944
prerequisite-patch-id: 387905b1da8b1293e7736b28fcc1585583e3e7cf
prerequisite-patch-id: 2fd7ac6c4dfd717ab117fc771623c01040188b4e
prerequisite-patch-id: bfeefd995e3f80d6fa0edfa2205d98be31fbee4e
prerequisite-patch-id: abcb5732607ad17f4c99c06b8bb83c9db1b15c42
prerequisite-patch-id: 5179e659d828bed48051d365f669a8ba3a36c206
--
2.20.1

\
 
 \ /
  Last update: 2020-05-27 18:42    [W:0.090 / U:0.136 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site