lkml.org 
[lkml]   [2020]   [May]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH 0/4] mm/gup, drm/i915: refactor gup_fast, convert to pin_user_pages()
Hi John,


On Tue, May 19, 2020 at 5:51 AM John Hubbard <jhubbard@nvidia.com> wrote:
>
> This needs to go through Andrew's -mm tree, due to adding a new gup.c
> routine. However, I would really love to have some testing from the
> drm/i915 folks, because I haven't been able to run-time test that part
> of it.
>
> Otherwise, though, the series has passed my basic run time testing:
> some LTP tests, some xfs and etx4 non-destructive xfstests, and an
> assortment of other smaller ones: vm selftests, io_uring_register, a
> few more. But that's only on one particular machine. Also, cross-compile
> tests for half a dozen arches all pass.
>
> Details:
>
> In order to convert the drm/i915 driver from get_user_pages() to
> pin_user_pages(), a FOLL_PIN equivalent of __get_user_pages_fast() was
> required. That led to refactoring __get_user_pages_fast(), with the
> following goals:
>
> 1) As above: provide a pin_user_pages*() routine for drm/i915 to call,
> in place of __get_user_pages_fast(),
>
> 2) Get rid of the gup.c duplicate code for walking page tables with
> interrupts disabled. This duplicate code is a minor maintenance
> problem anyway.
>
> 3) Make it easy for an upcoming patch from Souptick, which aims to
> convert __get_user_pages_fast() to use a gup_flags argument, instead
> of a bool writeable arg. Also, if this series looks good, we can
> ask Souptick to change the name as well, to whatever the consensus
> is. My initial recommendation is: get_user_pages_fast_only(), to
> match the new pin_user_pages_only().

Shall I hold my changes till 5.8-rc1 , when this series will appear upstream ?
>
> John Hubbard (4):
> mm/gup: move __get_user_pages_fast() down a few lines in gup.c
> mm/gup: refactor and de-duplicate gup_fast() code
> mm/gup: introduce pin_user_pages_fast_only()
> drm/i915: convert get_user_pages() --> pin_user_pages()
>
> drivers/gpu/drm/i915/gem/i915_gem_userptr.c | 22 +--
> include/linux/mm.h | 3 +
> mm/gup.c | 150 ++++++++++++--------
> 3 files changed, 107 insertions(+), 68 deletions(-)
>
>
> base-commit: 642b151f45dd54809ea00ecd3976a56c1ec9b53d
> --
> 2.26.2
>

\
 
 \ /
  Last update: 2020-05-22 13:41    [W:1.581 / U:0.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site