lkml.org 
[lkml]   [2020]   [May]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v13 4/8] iommu/vt-d: Add bind guest PASID support
Hi Christoph,

Thanks a lot for the reviews, comments below.

Jacob

On Wed, 13 May 2020 22:59:30 -0700
Christoph Hellwig <hch@infradead.org> wrote:

> > + if (dev_is_pci(dev)) {
> > + /* VT-d supports devices with full 20 bit PASIDs
> > only */
> > + if (pci_max_pasids(to_pci_dev(dev)) != PASID_MAX)
> > + return -EINVAL;
> > + } else {
> > + return -ENOTSUPP;
> > + }
>
> This looks strange. Why not:
>
> if (!dev_is_pci(dev)) {
> return -ENOTSUPP;
>
> /* VT-d supports devices with full 20 bit PASIDs only */
> if (pci_max_pasids(to_pci_dev(dev)) != PASID_MAX)
> return -EINVAL;
>
That is better, will do.

> > + for_each_svm_dev(sdev, svm, dev) {
> > + /*
> > + * For devices with aux domains, we should
> > allow multiple
> > + * bind calls with the same PASID and pdev.
> > + */
> > + if (iommu_dev_feature_enabled(dev,
> > IOMMU_DEV_FEAT_AUX)) {
> > + sdev->users++;
> > + } else {
> > + dev_warn_ratelimited(dev, "Already
> > bound with PASID %u\n",
> > + svm->pasid);
> > + ret = -EBUSY;
> > + }
> > + goto out;
>
> Is this intentionally a for loop that jumps out of the loop after
> the first device?
>
The name is confusing, it is not a loop. I will change it to
find_svm_dev() and comments like this?

/*
* Find the matching device in a given SVM. The bind code ensures that
* each device can only be added to the SVM list once.
*/
#define find_svm_dev(sdev, svm, d) \
list_for_each_entry((sdev), &(svm)->devs, list) \
if ((d) != (sdev)->dev) {} else

> > + /*
> > + * PASID table is per device for better security.
> > Therefore, for
> > + * each bind of a new device even with an existing PASID,
> > we need to
> > + * call the nested mode setup function here.
> > + */
> > + spin_lock(&iommu->lock);
> > + ret = intel_pasid_setup_nested(iommu,
> > + dev,
> > + (pgd_t *)data->gpgd,
> > + data->hpasid,
> > + &data->vtd,
> > + dmar_domain,
> > + data->addr_width);
>
> Why not:
>
> et = intel_pasid_setup_nested(iommu, dev, (pgd_t *)data->gpgd,
> data->hpasid, &data->vtd, dmar_domain,
> data->addr_width);
>
> ?
>
I thought we want to align the parentheses? Either way is fine.
Baolu?

> > + for_each_svm_dev(sdev, svm, dev) {
> > + ret = 0;
>
> ...
>
> > + break;
> > + }
>
> Same only looks at the first device style. Why dos it only care about
> the first device? That needs at least a comment, and probably a
> first_svm_dev or so heper to make it explicit.

Yes, same as above. change to find_svm_dev() since there should be at
most one matching device in the svm list.


\
 
 \ /
  Last update: 2020-05-14 17:52    [W:0.104 / U:0.352 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site