lkml.org 
[lkml]   [2020]   [Apr]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH 4.14 029/199] uapi: rename ext2_swab() to swab() and share globally in swab.h
    Date
    From: Yury Norov <yury.norov@gmail.com>

    [ Upstream commit d5767057c9a76a29f073dad66b7fa12a90e8c748 ]

    ext2_swab() is defined locally in lib/find_bit.c However it is not
    specific to ext2, neither to bitmaps.

    There are many potential users of it, so rename it to just swab() and
    move to include/uapi/linux/swab.h

    ABI guarantees that size of unsigned long corresponds to BITS_PER_LONG,
    therefore drop unneeded cast.

    Link: http://lkml.kernel.org/r/20200103202846.21616-1-yury.norov@gmail.com
    Signed-off-by: Yury Norov <yury.norov@gmail.com>
    Cc: Allison Randal <allison@lohutok.net>
    Cc: Joe Perches <joe@perches.com>
    Cc: Thomas Gleixner <tglx@linutronix.de>
    Cc: William Breathitt Gray <vilhelm.gray@gmail.com>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
    Signed-off-by: Sasha Levin <sashal@kernel.org>
    ---
    include/linux/swab.h | 1 +
    include/uapi/linux/swab.h | 10 ++++++++++
    lib/find_bit.c | 16 ++--------------
    3 files changed, 13 insertions(+), 14 deletions(-)

    diff --git a/include/linux/swab.h b/include/linux/swab.h
    index e466fd159c857..bcff5149861a9 100644
    --- a/include/linux/swab.h
    +++ b/include/linux/swab.h
    @@ -7,6 +7,7 @@
    # define swab16 __swab16
    # define swab32 __swab32
    # define swab64 __swab64
    +# define swab __swab
    # define swahw32 __swahw32
    # define swahb32 __swahb32
    # define swab16p __swab16p
    diff --git a/include/uapi/linux/swab.h b/include/uapi/linux/swab.h
    index 23cd84868cc3b..fa7f97da5b768 100644
    --- a/include/uapi/linux/swab.h
    +++ b/include/uapi/linux/swab.h
    @@ -4,6 +4,7 @@

    #include <linux/types.h>
    #include <linux/compiler.h>
    +#include <asm/bitsperlong.h>
    #include <asm/swab.h>

    /*
    @@ -132,6 +133,15 @@ static inline __attribute_const__ __u32 __fswahb32(__u32 val)
    __fswab64(x))
    #endif

    +static __always_inline unsigned long __swab(const unsigned long y)
    +{
    +#if BITS_PER_LONG == 64
    + return __swab64(y);
    +#else /* BITS_PER_LONG == 32 */
    + return __swab32(y);
    +#endif
    +}
    +
    /**
    * __swahw32 - return a word-swapped 32-bit value
    * @x: value to wordswap
    diff --git a/lib/find_bit.c b/lib/find_bit.c
    index 6ed74f78380ce..883ef3755a1cb 100644
    --- a/lib/find_bit.c
    +++ b/lib/find_bit.c
    @@ -133,18 +133,6 @@ EXPORT_SYMBOL(find_last_bit);

    #ifdef __BIG_ENDIAN

    -/* include/linux/byteorder does not support "unsigned long" type */
    -static inline unsigned long ext2_swab(const unsigned long y)
    -{
    -#if BITS_PER_LONG == 64
    - return (unsigned long) __swab64((u64) y);
    -#elif BITS_PER_LONG == 32
    - return (unsigned long) __swab32((u32) y);
    -#else
    -#error BITS_PER_LONG not defined
    -#endif
    -}
    -
    #if !defined(find_next_bit_le) || !defined(find_next_zero_bit_le)
    static unsigned long _find_next_bit_le(const unsigned long *addr,
    unsigned long nbits, unsigned long start, unsigned long invert)
    @@ -157,7 +145,7 @@ static unsigned long _find_next_bit_le(const unsigned long *addr,
    tmp = addr[start / BITS_PER_LONG] ^ invert;

    /* Handle 1st word. */
    - tmp &= ext2_swab(BITMAP_FIRST_WORD_MASK(start));
    + tmp &= swab(BITMAP_FIRST_WORD_MASK(start));
    start = round_down(start, BITS_PER_LONG);

    while (!tmp) {
    @@ -168,7 +156,7 @@ static unsigned long _find_next_bit_le(const unsigned long *addr,
    tmp = addr[start / BITS_PER_LONG] ^ invert;
    }

    - return min(start + __ffs(ext2_swab(tmp)), nbits);
    + return min(start + __ffs(swab(tmp)), nbits);
    }
    #endif

    --
    2.20.1


    \
     
     \ /
      Last update: 2020-04-22 12:10    [W:5.011 / U:0.152 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site