lkml.org 
[lkml]   [2020]   [Apr]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 0/3] KVM: x86: move nested-related kvm_x86_ops to a separate struct
From
Date
On 17/04/20 21:11, Sean Christopherson wrote:
> Ya, my vote would be to copy by value as well.

I'd rather avoid useless churn, because

vmx_x86_ops.nested = vmx_nested_ops;

is much uglier than

.nested = &vmx_nested_ops,

and with static calls the latter would not have any performance downside.

> I'd also be in favor of
> dropping the _ops part, e.g.
>
> struct kvm_x86_ops {
> struct kvm_x86_nested_ops nested;
>
> ...
> };
>
> and drop the "nested" parts from the ops, e.g.
>
> check_nested_events() -> check_events()

Agreed on both, I'll send v2 with these changes.

Paolo

\
 
 \ /
  Last update: 2020-04-18 11:57    [W:0.046 / U:0.948 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site