lkml.org 
[lkml]   [2020]   [Apr]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/5] staging: vt6656: Rebase all rejected patches
Date
This patch series makes a "rebase" of all the patches that were
previously rejected because they did not apply.

The first patch uses the error code returned by the vnt_control_out
function as the returned value of the vnt_rf_write_embedded function
instead of a boolean value. This way, the return value is an error code.
Also, fix all the vnt_rf_write_embedded calls accordingly.

The second patch uses the BIT() macro instead of the bit left shift
operator.

The third patch use the define RATE_11M present in the file "device.h"
instead of the magic number 3.

The fourth patch creates a constant array with the values of the
"phy->signal" variable for every rate and makes a refactor of the
assignment of this variable.

The fifth path takes out the "phy->service" assignment from the if-else
statement due to it's the same for the two branches.

Oscar Carter (5):
staging: vt6656: Return error code in vnt_rf_write_embedded function
staging: vt6656: Use BIT() macro instead of bit shift operator
staging: vt6656: Use define instead of magic number for tx_rate
staging: vt6656: Refactor the assignment of the phy->signal variable
staging: vt6656: Remove duplicate code for the phy->service assignment

drivers/staging/vt6656/baseband.c | 111 ++++++++----------------------
drivers/staging/vt6656/card.c | 4 +-
drivers/staging/vt6656/rf.c | 99 ++++++++++++++++----------
3 files changed, 95 insertions(+), 119 deletions(-)

--
2.20.1

\
 
 \ /
  Last update: 2020-04-14 17:41    [W:0.038 / U:0.448 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site