lkml.org 
[lkml]   [2020]   [Mar]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v3 6/8] dt-bindings: iio: adc: add bindings doc for AXI ADC driver
On Thu, Feb 27, 2020 at 10:27:17AM +0200, Alexandru Ardelean wrote:
> This change adds the bindings documentation for the AXI ADC driver.
>
> Signed-off-by: Alexandru Ardelean <alexandru.ardelean@analog.com>
> ---
> .../bindings/iio/adc/adi-axi-adc.yaml | 69 +++++++++++++++++++

Follow the compatible string: adi,axi-adc.yaml

> 1 file changed, 69 insertions(+)
> create mode 100644 Documentation/devicetree/bindings/iio/adc/adi-axi-adc.yaml
>
> diff --git a/Documentation/devicetree/bindings/iio/adc/adi-axi-adc.yaml b/Documentation/devicetree/bindings/iio/adc/adi-axi-adc.yaml
> new file mode 100644
> index 000000000000..d45d41f4f08e
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/iio/adc/adi-axi-adc.yaml
> @@ -0,0 +1,69 @@
> +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause)
> +%YAML 1.2
> +---
> +$id: http://devicetree.org/schemas/iio/adc/adi-axi-adc.yaml#
> +$schema: http://devicetree.org/meta-schemas/core.yaml#
> +
> +title: Analog Devices AXI ADC IP core
> +
> +maintainers:
> + - Michael Hennerich <michael.hennerich@analog.com>
> + - Alexandru Ardelean <alexandru.ardelean@analog.com>
> +
> +description: |
> + Analog Devices Generic AXI ADC IP core for interfacing an ADC device
> + with a high speed serial (JESD204B/C) or source synchronous parallel
> + interface (LVDS/CMOS).
> + Usually, some other interface type (i.e SPI) is used as a control
> + interface for the actual ADC, while this IP core will interface
> + to the data-lines of the ADC and handle the streaming of data into
> + memory via DMA.
> +
> + https://wiki.analog.com/resources/fpga/docs/axi_adc_ip
> +
> +properties:
> + compatible:
> + enum:
> + - adi,axi-adc-10.0.a
> +
> + reg:
> + maxItems: 1
> +
> + dmas:
> + minItems: 1
> + maxItems: 1

Just maxItems is enough.

> +
> + dma-names:
> + maxItems: 1
> + items:
> + - const: rx
> +
> + adi-axi-adc-client:

adi,axi-adc-client

Though I think 'adi,adc-dev' would be better name.

> + description:
> + A reference to a the actual ADC to which this FPGA ADC interfaces to.
> + maxItems: 1
> +
> +required:
> + - compatible
> + - dmas
> + - reg
> + - adi-axi-adc-client
> +
> +additionalProperties: false
> +
> +examples:
> + - |
> + fpga_axi {

You can drop this node.

> + #address-cells = <1>;
> + #size-cells = <1>;
> +
> + axi-adc@44a00000 {
> + compatible = "adi,axi-adc-10.0.a";
> + reg = <0x44a00000 0x10000>;
> + dmas = <&rx_dma 0>;
> + dma-names = "rx";
> +
> + adi-axi-adc-client = <&spi_adc>;
> + };
> + };
> +...
> --
> 2.20.1
>

\
 
 \ /
  Last update: 2020-03-03 17:55    [W:0.124 / U:1.048 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site