lkml.org 
[lkml]   [2020]   [Nov]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4] mm/oom_kill: change comment and rename is_dump_unreclaim_slabs()
On Sat 31-10-20 02:27:04, Hui Su wrote:
> Change the comment of is_dump_unreclaim_slabs(), it just check
> whether nr_unreclaimable slabs amount is greater than user
> memory, and explain why we dump unreclaim slabs.
>
> Rename it to should_dump_unreclaim_slab() maybe better.
>
> Signed-off-by: Hui Su <sh_def@163.com>

Acked-by: Michal Hocko <mhocko@suse.com>

Thanks!

> ---
> mm/oom_kill.c | 14 ++++++++------
> 1 file changed, 8 insertions(+), 6 deletions(-)
>
> diff --git a/mm/oom_kill.c b/mm/oom_kill.c
> index 8b84661a6410..04b19b7b5435 100644
> --- a/mm/oom_kill.c
> +++ b/mm/oom_kill.c
> @@ -170,11 +170,13 @@ static bool oom_unkillable_task(struct task_struct *p)
> return false;
> }
>
> -/*
> - * Print out unreclaimble slabs info when unreclaimable slabs amount is greater
> - * than all user memory (LRU pages)
> - */
> -static bool is_dump_unreclaim_slabs(void)
> +/**
> + * Check whether unreclaimable slab amount is greater than
> + * all user memory(LRU pages).
> + * dump_unreclaimable_slab() could help in the case that
> + * oom due to too much unreclaimable slab used by kernel.
> +*/
> +static bool should_dump_unreclaim_slab(void)
> {
> unsigned long nr_lru;
>
> @@ -463,7 +465,7 @@ static void dump_header(struct oom_control *oc, struct task_struct *p)
> mem_cgroup_print_oom_meminfo(oc->memcg);
> else {
> show_mem(SHOW_MEM_FILTER_NODES, oc->nodemask);
> - if (is_dump_unreclaim_slabs())
> + if (should_dump_unreclaim_slab())
> dump_unreclaimable_slab();
> }
> if (sysctl_oom_dump_tasks)
> --
> 2.29.0
>
>

--
Michal Hocko
SUSE Labs

\
 
 \ /
  Last update: 2020-11-02 08:29    [W:0.097 / U:0.056 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site