lkml.org 
[lkml]   [2020]   [Nov]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] reboot: remove cf9_safe from allowed types and rename cf9_force
Date
From: Matteo Croce <mcroce@microsoft.com>

BOOT_CF9_SAFE_STR is an internal value used only by the x86 code and
it's not possible to set it from userspace.

Remove it, and rename 'cf9_force' to 'pci', so to make it coherent with
the kernel command line reboot= option.

Tested with this script:

cd /sys/kernel/reboot/

for i in cold warm hard soft gpio; do
echo $i >mode
read j <mode
[ $i = $j ] || echo "mode $i != $j"
done

for i in bios acpi kbd triple efi pci; do
echo $i >type
read j <type
[ $i = $j ] || echo "type $i != $j"
done

for i in $(seq 0 $(nproc --ignore=1)); do
echo $i >cpu
read j <cpu
[ $i = $j ] || echo "cpu $i != $j"
done

for i in 0 1; do
echo $i >force
read j <force
[ $i = $j ] || echo "force $i != $j"
done

Fixes: eab8da48579d ("reboot: allow to specify reboot mode via sysfs")
Signed-off-by: Matteo Croce <mcroce@microsoft.com>
---
kernel/reboot.c | 12 +++---------
1 file changed, 3 insertions(+), 9 deletions(-)

diff --git a/kernel/reboot.c b/kernel/reboot.c
index 7cab92624267..77c51edc3928 100644
--- a/kernel/reboot.c
+++ b/kernel/reboot.c
@@ -609,8 +609,7 @@ __setup("reboot=", reboot_setup);
#define BOOT_BIOS_STR "bios"
#define BOOT_ACPI_STR "acpi"
#define BOOT_EFI_STR "efi"
-#define BOOT_CF9_FORCE_STR "cf9_force"
-#define BOOT_CF9_SAFE_STR "cf9_safe"
+#define BOOT_PCI_STR "pci"

static ssize_t mode_show(struct kobject *kobj, struct kobj_attribute *attr, char *buf)
{
@@ -682,10 +681,7 @@ static ssize_t type_show(struct kobject *kobj, struct kobj_attribute *attr, char
val = BOOT_EFI_STR;
break;
case BOOT_CF9_FORCE:
- val = BOOT_CF9_FORCE_STR;
- break;
- case BOOT_CF9_SAFE:
- val = BOOT_CF9_SAFE_STR;
+ val = BOOT_PCI_STR;
break;
default:
val = REBOOT_UNDEFINED_STR;
@@ -709,10 +705,8 @@ static ssize_t type_store(struct kobject *kobj, struct kobj_attribute *attr,
reboot_type = BOOT_ACPI;
else if (!strncmp(buf, BOOT_EFI_STR, strlen(BOOT_EFI_STR)))
reboot_type = BOOT_EFI;
- else if (!strncmp(buf, BOOT_CF9_FORCE_STR, strlen(BOOT_CF9_FORCE_STR)))
+ else if (!strncmp(buf, BOOT_PCI_STR, strlen(BOOT_PCI_STR)))
reboot_type = BOOT_CF9_FORCE;
- else if (!strncmp(buf, BOOT_CF9_SAFE_STR, strlen(BOOT_CF9_SAFE_STR)))
- reboot_type = BOOT_CF9_SAFE;
else
return -EINVAL;

--
2.28.0
\
 
 \ /
  Last update: 2020-11-13 03:01    [W:0.030 / U:1.276 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site