lkml.org 
[lkml]   [2020]   [Oct]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v4 3/4] mmc: sdhci-of-arasan: Add structure device pointer in probe
From
Date


On 08. 10. 20 4:09, muhammad.husaini.zulkifli@intel.com wrote:
> From: Muhammad Husaini Zulkifli <muhammad.husaini.zulkifli@intel.com>
>
> Add struct device *dev in probe func() so that it can widely use in
> probe to make code more readable.
>
> Signed-off-by: Muhammad Husaini Zulkifli <muhammad.husaini.zulkifli@intel.com>
> ---
> drivers/mmc/host/sdhci-of-arasan.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/mmc/host/sdhci-of-arasan.c b/drivers/mmc/host/sdhci-of-arasan.c
> index f186fbd016b1..46aea6516133 100644
> --- a/drivers/mmc/host/sdhci-of-arasan.c
> +++ b/drivers/mmc/host/sdhci-of-arasan.c
> @@ -1521,6 +1521,7 @@ static int sdhci_arasan_probe(struct platform_device *pdev)
> struct sdhci_pltfm_host *pltfm_host;
> struct sdhci_arasan_data *sdhci_arasan;
> struct device_node *np = pdev->dev.of_node;
> + struct device *dev = &pdev->dev;
> const struct sdhci_arasan_of_data *data;
>
> match = of_match_node(sdhci_arasan_of_match, pdev->dev.of_node);
>

This is not what we discussed. You create new variable and you should
just use it in that function.

s/pdev->dev\./dev->/g

Thanks,
Michal

\
 
 \ /
  Last update: 2020-10-08 09:35    [W:2.276 / U:0.524 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site