lkml.org 
[lkml]   [2020]   [Oct]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] IB/verbs: avoid nested container_of()
On Mon, Oct 26, 2020 at 05:15:39PM +0100, Arnd Bergmann wrote:
> From: Arnd Bergmann <arnd@arndb.de>
>
> Nested container_of() calls work correctly but cause a warning when
> building with W=2. Invoking it from an inline function like in
> drivers/infiniband/hw/mlx5/mlx5_ib.h means we get hundreds of
> warnings like:
>
> include/linux/kernel.h:852:8: warning: declaration of '__mptr' shadows a previous local [-Wshadow]
> 852 | void *__mptr = (void *)(ptr); \
> | ^~~~~~
> include/rdma/uverbs_ioctl.h:651:11: note: in expansion of macro 'container_of'
> 651 | (udata ? container_of(container_of(udata, struct uverbs_attr_bundle, \
> | ^~~~~~~~~~~~
> include/rdma/uverbs_ioctl.h:651:24: note: in expansion of macro 'container_of'
> 651 | (udata ? container_of(container_of(udata, struct uverbs_attr_bundle, \
> | ^~~~~~~~~~~~
> drivers/infiniband/hw/mthca/mthca_qp.c:564:35: note: in expansion of macro 'rdma_udata_to_drv_context'
> 564 | struct mthca_ucontext *context = rdma_udata_to_drv_context(
> | ^~~~~~~~~~~~~~~~~~~~~~~~~
> include/linux/kernel.h:852:8: note: shadowed declaration is here
> 852 | void *__mptr = (void *)(ptr); \
> | ^~~~~~
> include/rdma/uverbs_ioctl.h:651:11: note: in expansion of macro 'container_of'
> 651 | (udata ? container_of(container_of(udata, struct uverbs_attr_bundle, \
> | ^~~~~~~~~~~~
> drivers/infiniband/hw/mthca/mthca_qp.c:564:35: note: in expansion of macro 'rdma_udata_to_drv_context'
> 564 | struct mthca_ucontext *context = rdma_udata_to_drv_context(
> | ^~~~~~~~~~~~~~~~~~~~~~~~~
> In file included from <command-line>:
> include/linux/kernel.h:852:8: warning: declaration of '__mptr' shadows a previous local [-Wshadow]
> 852 | void *__mptr = (void *)(ptr); \
> | ^~~~~~
>
> Rewrite the macro to use an inline function internally, which makes
> it more readable and reduces the amount of useless output from
> make W=2.
>
> Fixes: 730623f4a56f ("IB/verbs: Add helper function rdma_udata_to_drv_context")
> Signed-off-by: Arnd Bergmann <arnd@arndb.de>
> ---
> include/rdma/uverbs_ioctl.h | 15 +++++++++------
> 1 file changed, 9 insertions(+), 6 deletions(-)

Applied to rdma for-next, thanks

Jason

\
 
 \ /
  Last update: 2020-10-28 23:56    [W:0.081 / U:0.160 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site