lkml.org 
[lkml]   [2020]   [Oct]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v7 1/4] powerpc: Refactor kexec functions to move arch independent code to kernel
From
Date
On 10/20/20 1:00 PM, Mimi Zohar wrote:
> Hi Lakshmi,
>
> On Wed, 2020-09-30 at 13:59 -0700, Lakshmi Ramasubramanian wrote:
>> The functions remove_ima_buffer() and delete_fdt_mem_rsv() that handle
>> carrying forward the IMA measurement logs on kexec for powerpc do not
>> have architecture specific code, but they are currently defined for
>> powerpc only.
>>
>> remove_ima_buffer() and delete_fdt_mem_rsv() are used to remove
>> the IMA log entry from the device tree and free the memory reserved
>> for the log. These functions need to be defined even if the current
>> kernel does not support carrying forward IMA log across kexec since
>> the previous kernel could have supported that and therefore the current
>> kernel needs to free the allocation.
>>
>> Rename remove_ima_buffer() to remove_ima_kexec_buffer().
>> Define remove_ima_kexec_buffer() and delete_fdt_mem_rsv() in kernel.
>> A later patch in this series will use these functions to free
>> the allocation, if any, made by the previous kernel for ARM64.
>>
>> Define FDT_PROP_IMA_KEXEC_BUFFER for the chosen node, namely
>> "linux,ima-kexec-buffer", that is added to the DTB to hold
>> the address and the size of the memory reserved to carry
>> the IMA measurement log.
>
>> Co-developed-by: Prakhar Srivastava <prsriva@linux.microsoft.com>
>> Signed-off-by: Prakhar Srivastava <prsriva@linux.microsoft.com>
>> Signed-off-by: Lakshmi Ramasubramanian <nramas@linux.microsoft.com>
>> Reported-by: kernel test robot <lkp@intel.com> error: implicit declaration of function 'delete_fdt_mem_rsv' [-Werror,-Wimplicit-function-declaration]
>
> Much better! This version limits unnecessarily changing the existing
> code to adding a couple of debugging statements, but that looks to be
> about it.
Yes Mimi - that's correct.

>
> Based on Chester Lin's "ima_arch" support for arm64 discussion, the IMA generic
> EFI support will be defined in ima/ima-efi.c. Similarly, I think it would make sense to put the generic device tree support in ima/ima_kexec_fdt.c or ima/ima_fdt.c, as opposed to kernel/. (Refer to my comments on 2/4 about the new file named ima_kexec_fdt.c.)

The functions remove_ima_kexec_buffer() and delete_fdt_mem_rsv(), which
are defined in kernel/ima_kexec.c and kernel/kexec_file_fdt.c
respectively, are needed even when CONFIG_IMA is not defined. These
functions need to be called by the current kernel to free the ima kexec
buffer resources allocated by the previous kernel. This is the reason,
these functions are defined under "kernel" instead of
"security/integrity/ima".

If there is a better location to move the above C files, please let me
know. I'll move them.

thanks,
-lakshmi


\
 
 \ /
  Last update: 2020-10-21 04:25    [W:0.099 / U:0.052 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site