lkml.org 
[lkml]   [2019]   [Aug]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] [semaphore] Removed redundant code from semaphore's down family of function
On Mon, Aug 12, 2019 at 05:31:43AM +0000, Satendra Singh Thakur wrote:
> -The semaphore code has four funcs
> down,
> down_interruptible,
> down_killable,
> down_timeout
> -These four funcs have almost similar code except that
> they all call lower level function __down_xyz.
> -This lower level func in-turn call inline func
> __down_common with appropriate arguments.
> -This patch creates a common macro for above family of funcs
> so that duplicate code is eliminated.
> -Also, __down_common has been made noinline so that code is
> functionally similar to previous one
> -For example, earlier down_killable would call __down_killable
> , which in-turn would call inline func __down_common
> Now, down_killable calls noinline __down_common directly
> through a macro
> -The funcs __down_interruptible, __down_killable etc have been
> removed as they were just wrapper to __down_common
>
> Signed-off-by: Satendra Singh Thakur <satendrasingh.thakur@hcl.com>
> ---
> kernel/locking/semaphore.c | 107 +++++++++++++------------------------
> 1 file changed, 38 insertions(+), 69 deletions(-)

Something has gone very wrong with your mail setup, so this patch is
mangled beyond repair.

Please read Documentation/process/email-clients.rst and also work with
your employer to remove the disclaimer at the end of your email too.

Thanks,

Will

\
 
 \ /
  Last update: 2019-08-12 11:13    [W:0.105 / U:0.012 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site