lkml.org 
[lkml]   [2019]   [Jul]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/5] sched/fair: rename sum_nr_running to sum_h_nr_running
* Vincent Guittot <vincent.guittot@linaro.org> [2019-07-19 09:58:22]:

> sum_nr_running will track rq->nr_running task and sum_h_nr_running
> will track cfs->h_nr_running so we can use both to detect when other
> scheduling class are running and preempt CFS.
>
> There is no functional changes.
>
> Signed-off-by: Vincent Guittot <vincent.guittot@linaro.org>
> ---
>
> ld_moved = 0;
> - if (busiest->nr_running > 1) {
> + if (busiest->cfs.h_nr_running > 1) {

We should be looking for nr_running here.
There could be only one cfs task but that may not be the current running
task, so it could be a good one to be picked for load balancing.

No?

> /*
> * Attempt to move tasks. If find_busiest_group has found
> * an imbalance but busiest->nr_running <= 1, the group is
> --
> 2.7.4
>

--
Thanks and Regards
Srikar Dronamraju

\
 
 \ /
  Last update: 2019-07-26 04:18    [W:0.251 / U:0.604 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site