lkml.org 
[lkml]   [2019]   [May]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Subject[PATCH v6 00/10] add USB Type-B GPIO connector driver
    Date
    Because the USB Connector is introduced and the requirement of
    usb-connector.txt binding, the old way using extcon to support
    USB Dual-Role switch is now deprecated, meanwhile there is no
    available common driver when use Type-B connector, typically
    using an input GPIO to detect USB ID pin.
    This patch series introduce a Type-B GPIO connector driver and try
    to replace the function provided by extcon-usb-gpio driver.

    v6 changes:
    1. merge [1] and [2] into this series
    2. don't use graph anymore to find usb-role-switch
    3. abandon [3] and introduce three patches (6, 7, 8 in this series)
    to rebuild APIs getting usb-role-switch

    [1]: [v3] dt-binding: usb: add usb-role-switch property
    https://patchwork.kernel.org/patch/10934835/
    [2]: [v6,08/13] usb: roles: Introduce stubs for the exiting functions in role.h
    https://patchwork.kernel.org/patch/10909971/

    [3]: [PATCH v5 4/6] usb: roles: add API to get usb_role_switch by node

    v5 changes:
    1. remove linux/of.h and put usb_role_switch when error happens,
    suggested by Biju
    2. treat Type-B connector as USB controller's child, but not as
    a virtual device, suggested by Rob
    3. provide and use generic property "usb-role-switch", see [1],
    suggested by Rob

    Note: this series still depends on [2]

    [1]: [v3] dt-binding: usb: add usb-role-switch property
    https://patchwork.kernel.org/patch/10934835/
    [2]: [v6,08/13] usb: roles: Introduce stubs for the exiting functions in role.h
    https://patchwork.kernel.org/patch/10909971/

    v4 changes:
    1. use switch_fwnode_match() to find fwnode suggested by Heikki
    2. assign fwnode member of usb_role_switch struct suggested by Heikki
    3. make [4/6] depend on [2]
    3. remove linux/gpio.h suggested by Linus
    4. put node when error happens

    [4/6] usb: roles: add API to get usb_role_switch by node
    [2] [v6,08/13] usb: roles: Introduce stubs for the exiting functions in role.h
    https://patchwork.kernel.org/patch/10909971/

    v3 changes:
    1. add GPIO direction, and use fixed-regulator for GPIO controlled
    VBUS regulator suggested by Rob;
    2. rebuild fwnode_usb_role_switch_get() suggested by Andy and Heikki
    3. treat the type-B connector as a virtual device;
    4. change file name of driver again
    5. select USB_ROLE_SWITCH in mtu3/Kconfig suggested by Heikki
    6. rename ssusb_mode_manual_switch() to ssusb_mode_switch()

    v2 changes:
    1. make binding clear, and add a extra compatible suggested by Hans

    Chunfeng Yun (7):
    dt-binding: usb: add usb-role-switch property
    dt-bindings: connector: add optional properties for Type-B
    dt-bindings: usb: add binding for Type-B GPIO connector driver
    dt-bindings: usb: mtu3: add properties about USB Role Switch
    usb: roles: get usb-role-switch from parent
    usb: roles: add USB Type-B GPIO connector driver
    usb: mtu3: register a USB Role Switch for dual role mode

    Heikki Krogerus (2):
    device connection: Add fwnode_connection_find_match()
    usb: roles: Add fwnode_usb_role_switch_get() function

    Yu Chen (1):
    usb: roles: Introduce stubs for the exiting functions in role.h.

    .../bindings/connector/usb-connector.txt | 14 +
    .../devicetree/bindings/usb/generic.txt | 4 +
    .../devicetree/bindings/usb/mediatek,mtu3.txt | 10 +
    .../bindings/usb/typeb-conn-gpio.txt | 30 ++
    drivers/base/devcon.c | 33 +-
    drivers/usb/mtu3/Kconfig | 1 +
    drivers/usb/mtu3/mtu3.h | 5 +
    drivers/usb/mtu3/mtu3_debugfs.c | 4 +-
    drivers/usb/mtu3/mtu3_dr.c | 48 ++-
    drivers/usb/mtu3/mtu3_dr.h | 6 +-
    drivers/usb/mtu3/mtu3_plat.c | 3 +-
    drivers/usb/roles/Kconfig | 11 +
    drivers/usb/roles/Makefile | 1 +
    drivers/usb/roles/class.c | 41 ++-
    drivers/usb/roles/typeb-conn-gpio.c | 286 ++++++++++++++++++
    include/linux/device.h | 10 +-
    include/linux/usb/role.h | 37 +++
    17 files changed, 524 insertions(+), 20 deletions(-)
    create mode 100644 Documentation/devicetree/bindings/usb/typeb-conn-gpio.txt
    create mode 100644 drivers/usb/roles/typeb-conn-gpio.c

    --
    2.21.0

    \
     
     \ /
      Last update: 2019-05-29 09:44    [W:4.497 / U:0.124 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site