lkml.org 
[lkml]   [2019]   [Mar]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/6] bitmap_parselist: move non-parser logic to helpers
On Tue, 26 Mar 2019 00:07:44 +0300 Yury Norov <yury.norov@gmail.com> wrote:

> --- a/lib/bitmap.c
> +++ b/lib/bitmap.c
> @@ -477,6 +477,42 @@ int bitmap_print_to_pagebuf(bool list, char *buf, const unsigned long *maskp,
> }
> EXPORT_SYMBOL(bitmap_print_to_pagebuf);
>
> +/*
> + * Region 9-38:4/10 describes the following bitmap structure:
> + * 0 9 12 18 38
> + * .........****......****......****......
> + * ^ ^ ^ ^
> + * start off grlen end
> + */
> +struct region {
> + unsigned int start;
> + unsigned int off;
> + unsigned int grlen;
> + unsigned int end;
> +};

grlen means... group_len, I think?

Perhaps it should be called group_len ;)

\
 
 \ /
  Last update: 2019-03-25 22:54    [W:0.132 / U:0.176 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site