lkml.org 
[lkml]   [2019]   [Dec]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 19/24] xfs: rename compat_time_t to old_time32_t
On Fri, Dec 13, 2019 at 09:53:47PM +0100, Arnd Bergmann wrote:
> The compat_time_t type has been removed everywhere else,
> as most users rely on old_time32_t for both native and
> compat mode handling of 32-bit time_t.
>
> Remove the last one in xfs.
>
> Signed-off-by: Arnd Bergmann <arnd@arndb.de>

Looks fine to me, assuming that compat_time_t -> old_time32_t.
Reviewed-by: Darrick J. Wong <darrick.wong@oracle.com>

--D

> ---
> fs/xfs/xfs_ioctl32.c | 2 +-
> fs/xfs/xfs_ioctl32.h | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/fs/xfs/xfs_ioctl32.c b/fs/xfs/xfs_ioctl32.c
> index c4c4f09113d3..a49bd80b2c3b 100644
> --- a/fs/xfs/xfs_ioctl32.c
> +++ b/fs/xfs/xfs_ioctl32.c
> @@ -107,7 +107,7 @@ xfs_ioctl32_bstime_copyin(
> xfs_bstime_t *bstime,
> compat_xfs_bstime_t __user *bstime32)
> {
> - compat_time_t sec32; /* tv_sec differs on 64 vs. 32 */
> + old_time32_t sec32; /* tv_sec differs on 64 vs. 32 */
>
> if (get_user(sec32, &bstime32->tv_sec) ||
> get_user(bstime->tv_nsec, &bstime32->tv_nsec))
> diff --git a/fs/xfs/xfs_ioctl32.h b/fs/xfs/xfs_ioctl32.h
> index 8c7743cd490e..053de7d894cd 100644
> --- a/fs/xfs/xfs_ioctl32.h
> +++ b/fs/xfs/xfs_ioctl32.h
> @@ -32,7 +32,7 @@
> #endif
>
> typedef struct compat_xfs_bstime {
> - compat_time_t tv_sec; /* seconds */
> + old_time32_t tv_sec; /* seconds */
> __s32 tv_nsec; /* and nanoseconds */
> } compat_xfs_bstime_t;
>
> --
> 2.20.0
>

\
 
 \ /
  Last update: 2019-12-13 22:19    [W:0.393 / U:0.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site