lkml.org 
[lkml]   [2019]   [Jan]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v3 1/2] spi: support inter-word delay requirement for devices
From
Date
Hi,

On 28/01/2019 19:10, Mark Brown wrote:
> On Sat, Jan 26, 2019 at 05:32:19PM +0100, Jonas Bonn wrote:
>
>> @@ -164,6 +166,7 @@ struct spi_device {
>> char modalias[SPI_NAME_SIZE];
>> const char *driver_override;
>> int cs_gpio; /* chip select gpio */
>> + uint16_t word_delay; /* inter-word delay (us) */
>
> This needs some code in the core joining it up with the per-transfer
> word delay similar to what we have for speed_hz and bits_per_word in
> __spi_validate(). Then the controller drivers can just look at the
> per-transfer value and support both without having to duplicate logic.
>

So spi_transfer already has a field word_delay and it's defined as
_clock cycles_ to delay between words. I defined word_delay in
spi_device as _microseconds_ to delay along the lines of delay_usecs.

Given that the inter-word delay is a function of the slave device speed
and not of the SPI bus speed, I'm inclined to say that a time-based
delay is what we want (to be independent of bus speed). As such, I want
to know if I should add word_delay_usecs to _both_ spi_transfer and
spi_device?

There's only one user of word_delay from spi_transfer. Just looking at
it quickly, it looks like it wants the word_delay in
SPI-controller-clock cycles and not SCK cycles which seems pretty broken
to me. Adding Baolin and Lanqing to CC: for comment. Could we rework
that to be microseconds and do the calculation in the driver?

Thanks,
Jonas

\
 
 \ /
  Last update: 2019-01-28 22:29    [W:0.052 / U:0.256 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site