lkml.org 
[lkml]   [2018]   [Sep]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v3 18/30] iio: adc: sun4i-gpadc-iio: rework: support multiple sensors
From
Date
On 02.09.2018 22:11, Jonathan Cameron wrote:
> This feels like a good place to factor out the code into a utility
> function that just does one of them. That should hopefully
> reduce the indenting etc enough to make the code easier to read.
>
>> + info->tzds[i].info = info;
>> + info->tzds[i].sensor_id = i;
>> +
>> + info->tzds[i].tzd = thermal_zone_of_sensor_register(
>> + info->sensor_device,
>> + i, &info->tzds[i], &sun4i_ts_tz_ops);
>> + /*
>> + * Do not fail driver probing when failing to register in
>> + * thermal because no thermal DT node is found.
>> + */
>> + if (IS_ERR(info->tzds[i].tzd) && \
>> + PTR_ERR(info->tzds[i].tzd) != -ENODEV) {
>> + dev_err(&pdev->dev,
>> + "could not register thermal sensor: %ld\n",
>> + PTR_ERR(info->tzds[i].tzd));
>> + return PTR_ERR(info->tzds[i].tzd);
>> + }

So this code above should be placed in a separate function and called by
the for loop?
Did I understand that right?

Philipp

\
 
 \ /
  Last update: 2018-09-03 15:59    [W:0.960 / U:0.644 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site