[lkml]   [2018]   [Aug]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] Raise the minimum required gcc version to 4.6
On Thu, Aug 23, 2018 at 2:52 PM Geert Uytterhoeven <> wrote:
> Thanks for your patch!
> I'm willing to upgrade. But there's one thing that's holding me back.
> Does gcc 8.x gives again the same warnings as my venerable old gcc 4.1.2,
> that no one else seems to see? Or will the real bugs I detect this way stay
> unfixed? Polyculture is a good thing, also in compilers.

Hi Geert,
Just for folks who may be missing context on this thread, like myself,
can you provide links to more information? If I understand your
question correctly, it seems that warnings were removed from gcc since
4.1.2? And that bugs have been caught by testing with gcc 4.1.2 (can
you provide commit sha's)? I assume you've already discussed such an
issue with the gcc maintainers (can you provide links to those
discussions)? Sorry, if this has already been discussed already on
LKML, but even a post that had all this information would be immensely
helpful in understanding your plight.

~Nick Desaulniers

 \ /
  Last update: 2018-08-24 00:01    [W:0.126 / U:0.880 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site