lkml.org 
[lkml]   [2018]   [Aug]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    Date
    Subject[PATCH] inet/connection_sock: prefer _THIS_IP_ to current_text_addr
    From
    As part of the effort to reduce the code duplication between _THIS_IP_
    and current_text_addr(), let's consolidate callers of
    current_text_addr() to use _THIS_IP_.

    Signed-off-by: Nick Desaulniers <ndesaulniers@google.com>
    ---
    include/net/inet_connection_sock.h | 3 ++-
    1 file changed, 2 insertions(+), 1 deletion(-)

    diff --git a/include/net/inet_connection_sock.h b/include/net/inet_connection_sock.h
    index 0a6c9e0f2b5a..f2a87e85c07b 100644
    --- a/include/net/inet_connection_sock.h
    +++ b/include/net/inet_connection_sock.h
    @@ -19,6 +19,7 @@
    #include <linux/string.h>
    #include <linux/timer.h>
    #include <linux/poll.h>
    +#include <linux/kernel.h>

    #include <net/inet_sock.h>
    #include <net/request_sock.h>
    @@ -224,7 +225,7 @@ static inline void inet_csk_reset_xmit_timer(struct sock *sk, const int what,

    if (when > max_when) {
    pr_debug("reset_xmit_timer: sk=%p %d when=0x%lx, caller=%p\n",
    - sk, what, when, current_text_addr());
    + sk, what, when, (void *)_THIS_IP_);
    when = max_when;
    }

    --
    2.18.0.597.ga71716f1ad-goog
    \
     
     \ /
      Last update: 2018-08-01 23:58    [W:4.218 / U:0.040 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site