lkml.org 
[lkml]   [2018]   [May]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH 2/6] x86: bug: prevent gcc distortions
    On Thu, May 17, 2018 at 09:13:58AM -0700, Nadav Amit wrote:
    > +asm(".macro __BUG_FLAGS ins:req file:req line:req flags:req size:req\n"
    > + "1:\t \\ins\n\t"
    > + ".pushsection __bug_table,\"aw\"\n"
    > + "2:\t "__BUG_REL(1b) "\t# bug_entry::bug_addr\n\t"
    > + __BUG_REL(\\file) "\t# bug_entry::file\n\t"
    > + ".word \\line" "\t# bug_entry::line\n\t"
    > + ".word \\flags" "\t# bug_entry::flags\n\t"
    > + ".org 2b+\\size\n\t"
    > + ".popsection\n\t"
    > + ".endm");
    > +
    > +#define _BUG_FLAGS(ins, flags) \
    > do { \
    > + asm volatile("__BUG_FLAGS \"" ins "\" %c0 %c1 %c2 %c3" \
    > + : : "i" (__FILE__), "i" (__LINE__), \
    > + "i" (flags), \
    > "i" (sizeof(struct bug_entry))); \
    > } while (0)

    This is an awesome hack, but is there really nothing we can do to make
    it more readable? Esp, that global asm doing the macro definition is a
    pain to read.

    Also, can we pretty please used named operands in 'new' code?

    \
     
     \ /
      Last update: 2018-05-18 10:00    [W:4.040 / U:0.416 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site