lkml.org 
[lkml]   [2018]   [Apr]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH 4.14 023/183] RDMA/core: Clarify rdma_ah_find_type
    Date
    4.14-stable review patch.  If anyone has any objections, please let me know.

    ------------------

    From: Parav Pandit <parav@mellanox.com>


    [ Upstream commit a6532e7139660c103dda181aa5b2c734aa26ed6c ]

    iWARP does not use rdma_ah_attr_type, and for this reason we do not have a
    RDMA_AH_ATTR_TYPE_IWARP. rdma_ah_find_type should not even be called on iwarp
    ports and for clarity it shouldn't have a special test for iWarp.

    This changes the result from RDMA_AH_ATTR_TYPE_ROCE to RDMA_AH_ATTR_TYPE_IB
    when wrongly called on an iWarp port.

    Fixes: 44c58487d51a ("IB/core: Define 'ib' and 'roce' rdma_ah_attr types")
    Signed-off-by: Parav Pandit <parav@mellanox.com>
    Signed-off-by: Leon Romanovsky <leon@kernel.org>
    Signed-off-by: Jason Gunthorpe <jgg@mellanox.com>
    Signed-off-by: Sasha Levin <alexander.levin@microsoft.com>
    Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
    ---
    include/rdma/ib_verbs.h | 3 +--
    1 file changed, 1 insertion(+), 2 deletions(-)

    --- a/include/rdma/ib_verbs.h
    +++ b/include/rdma/ib_verbs.h
    @@ -3766,8 +3766,7 @@ static inline void rdma_ah_set_grh(struc
    static inline enum rdma_ah_attr_type rdma_ah_find_type(struct ib_device *dev,
    u32 port_num)
    {
    - if ((rdma_protocol_roce(dev, port_num)) ||
    - (rdma_protocol_iwarp(dev, port_num)))
    + if (rdma_protocol_roce(dev, port_num))
    return RDMA_AH_ATTR_TYPE_ROCE;
    else if ((rdma_protocol_ib(dev, port_num)) &&
    (rdma_cap_opa_ah(dev, port_num)))

    \
     
     \ /
      Last update: 2018-04-25 12:38    [W:4.040 / U:0.240 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site