lkml.org 
[lkml]   [2018]   [Apr]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Subject[PATCH v3 0/5] Use of_clk_get_parent_count() instead of open coding
    Date
    	Hi Mike, Stephen, et al,

    This patch series replaces open-coded versions of
    of_clk_get_parent_count() by calls to the helper function.

    Changes compared to v2:
    - Add Acked-by, Reviewed-by,
    - Add SPDX-License-Identifier to <linux/of_clk.h>,
    - Add <linux/of_clk.h> to clock section in MAINTAINERS (note that Rob
    is still listed as a maintainer, too, due to the include/linux/of*.h
    catch-all rule),

    Changes compared to v1:
    - Move OF clock helpers (a.o. of_clk_get_parent_count()) to their own
    include file <linux/of_clk.h>, as suggested by Stephen,
    - Update includes for the above change,
    - Fix timer-sp804, now a dummy is available in the !CONFIG_COMMON_CLK
    case,
    - Fix a new occurrence.

    Note that patches 2-5 depend on the first patch.

    Thanks!

    Geert Uytterhoeven (5):
    clk: Extract OF clock helpers in <linux/of_clk.h>
    ARM: timer-sp: Use of_clk_get_parent_count() instead of open coding
    soc: rockchip: power-domain: Use of_clk_get_parent_count() instead of
    open coding
    soc/tegra: pmc: Use of_clk_get_parent_count() instead of open coding
    pinctrl: sunxi: Use of_clk_get_parent_count() instead of open coding

    MAINTAINERS | 1 +
    drivers/clocksource/timer-sp804.c | 3 ++-
    drivers/pinctrl/sunxi/pinctrl-sunxi.c | 4 ++--
    drivers/soc/rockchip/pm_domains.c | 4 ++--
    drivers/soc/tegra/pmc.c | 3 ++-
    include/linux/clk-provider.h | 14 +-------------
    include/linux/of_clk.h | 30 ++++++++++++++++++++++++++++++
    7 files changed, 40 insertions(+), 19 deletions(-)
    create mode 100644 include/linux/of_clk.h

    --
    2.7.4

    Gr{oetje,eeting}s,

    Geert

    --
    Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

    In personal conversations with technical people, I call myself a hacker. But
    when I'm talking to journalists I just say "programmer" or something like that.
    -- Linus Torvalds

    \
     
     \ /
      Last update: 2018-04-18 16:51    [W:3.998 / U:0.096 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site