lkml.org 
[lkml]   [2018]   [Feb]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v10 1/7] PCI/AER: Rename error recovery to generic pci naming
On 2018-02-23 00:04, Christoph Hellwig wrote:
> On Thu, Feb 22, 2018 at 09:32:06PM +0530, Oza Pawandeep wrote:
>> This patch renames error recovery to generic name with pci prefix
>>
>> Signed-off-by: Oza Pawandeep <poza@codeaurora.org>
>>
>> diff --git a/drivers/pci/pcie/aer/aerdrv_core.c
>> b/drivers/pci/pcie/aer/aerdrv_core.c
>> index a4bfea5..306bf2f 100644
>> --- a/drivers/pci/pcie/aer/aerdrv_core.c
>> +++ b/drivers/pci/pcie/aer/aerdrv_core.c
>> @@ -478,7 +478,7 @@ static pci_ers_result_t reset_link(struct pci_dev
>> *dev)
>> }
>>
>> /**
>> - * do_recovery - handle nonfatal/fatal error recovery process
>> + * pci_do_recovery - handle nonfatal/fatal error recovery process
>> * @dev: pointer to a pci_dev data structure of agent detecting an
>> error
>> * @severity: error severity type
>> *
>> @@ -486,7 +486,7 @@ static pci_ers_result_t reset_link(struct pci_dev
>> *dev)
>> * error detected message to all downstream drivers within a
>> hierarchy in
>> * question and return the returned code.
>> */
>> -static void do_recovery(struct pci_dev *dev, int severity)
>> +static void pci_do_recovery(struct pci_dev *dev, int severity)
>
> Maybe pcie_do_recovery?
>

sure will take care.
Thanks.

> Otherwise looks fine:
>
> Reviewed-by: Christoph Hellwig <hch@lst.de>

\
 
 \ /
  Last update: 2018-02-23 06:25    [W:0.607 / U:0.136 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site