lkml.org 
[lkml]   [2018]   [Oct]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH 3/6] cpuidle: menu: Get rid of first_idx from menu_select()
On Thu, Oct 4, 2018 at 9:46 AM Peter Zijlstra <peterz@infradead.org> wrote:
>
> On Tue, Oct 02, 2018 at 11:44:06PM +0200, Rafael J. Wysocki wrote:
> > idx = -1;
> > - for (i = first_idx; i < drv->state_count; i++) {
> > + for (i = 0; i < drv->state_count; i++) {
> > struct cpuidle_state *s = &drv->states[i];
> > struct cpuidle_state_usage *su = &dev->states_usage[i];
> >
> > if (s->disabled || su->disable)
> > continue;
> > +
> > if (idx == -1)
> > idx = i; /* first enabled state */
> > +
> > if (s->target_residency > predicted_us) {
> > + /*
> > + * Use a physical idle state, not busy polling, unless
> > + * a timer is going to trigger really really soon.
> > + */
> > + if ((drv->states[idx].flags & CPUIDLE_FLAG_POLLING) &&
> > + i == idx + 1 && latency_req > s->exit_latency &&
> > + data->next_timer_us > max_t(unsigned int, 20,
> > + s->target_residency)) {
>
> Not new in this patch, but this is where I really noticed it; that 20,
> should that not be something like: POLL_IDLE_TIME_LIMIT / NSEC_PER_USEC
> ?

The POLL_IDLE_TIME_LIMIT is how much time we allow it to spin in
idle_poll() and I'm not sure it is related. Besides, I want it to go
away actually (https://patchwork.kernel.org/patch/10624117/).

I could use a separate symbol for this particular magic number, but it
has been magic forever and it is used just in this one place, so ...

\
 
 \ /
  Last update: 2018-10-04 09:55    [W:0.087 / U:0.384 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site