lkml.org 
[lkml]   [2018]   [Oct]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 2/3] staging: rtl8188eu: cleanup array declaration - style
From
Date
On Wed, 2018-10-03 at 22:43 +0200, Michael Straube wrote:
> Cleanup array declaration to clear two 'line over 80 characters'
> checkpatch warnings and improve readability.
[]
> diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
[]
> @@ -3836,24 +3836,20 @@ Following are the initialization functions for WiFi MLME
> *****************************************************************************/
>
> static struct mlme_handler mlme_sta_tbl[] = {
> - {WIFI_ASSOCREQ, "OnAssocReq", &OnAssocReq},
> - {WIFI_ASSOCRSP, "OnAssocRsp", &OnAssocRsp},
> - {WIFI_REASSOCREQ, "OnReAssocReq", &OnAssocReq},
> - {WIFI_REASSOCRSP, "OnReAssocRsp", &OnAssocRsp},
> - {WIFI_PROBEREQ, "OnProbeReq", &OnProbeReq},
> - {WIFI_PROBERSP, "OnProbeRsp", &OnProbeRsp},
> -
> - /*----------------------------------------------------------
> - below 2 are reserved
> - -----------------------------------------------------------*/
> - {0, "DoReserved", &DoReserved},
> - {0, "DoReserved", &DoReserved},
> - {WIFI_BEACON, "OnBeacon", &OnBeacon},
> - {WIFI_ATIM, "OnATIM", &OnAtim},
> - {WIFI_DISASSOC, "OnDisassoc", &OnDisassoc},
> - {WIFI_AUTH, "OnAuth", &OnAuthClient},
> - {WIFI_DEAUTH, "OnDeAuth", &OnDeAuth},
> - {WIFI_ACTION, "OnAction", &OnAction},
> + {WIFI_ASSOCREQ, "OnAssocReq", &OnAssocReq},
> + {WIFI_ASSOCRSP, "OnAssocRsp", &OnAssocRsp},
> + {WIFI_REASSOCREQ, "OnReAssocReq", &OnAssocReq},
> + {WIFI_REASSOCRSP, "OnReAssocRsp", &OnAssocRsp},
> + {WIFI_PROBEREQ, "OnProbeReq", &OnProbeReq},
> + {WIFI_PROBERSP, "OnProbeRsp", &OnProbeRsp},
> + {0, "DoReserved", &DoReserved},
> + {0, "DoReserved", &DoReserved},
> + {WIFI_BEACON, "OnBeacon", &OnBeacon},
> + {WIFI_ATIM, "OnATIM", &OnAtim},
> + {WIFI_DISASSOC, "OnDisassoc", &OnDisassoc},
> + {WIFI_AUTH, "OnAuth", &OnAuthClient},
> + {WIFI_DEAUTH, "OnDeAuth", &OnDeAuth},
> + {WIFI_ACTION, "OnAction", &OnAction},
> };

Perhaps const here too, and as well, the struct
declaration could use const char * instead of char *



\
 
 \ /
  Last update: 2018-10-03 23:31    [W:0.175 / U:0.416 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site