lkml.org 
[lkml]   [2018]   [Oct]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH v2] bit_spinlock: introduce smp_cond_load_relaxed
Date
It is better to use wrapped smp_cond_load_relaxed
instead of open-coded busy waiting for bit_spinlock.

Signed-off-by: Gao Xiang <gaoxiang25@huawei.com>
---

change log v2:
- fix the incorrect expression !(VAL >> (bitnum & (BITS_PER_LONG-1)))
- the test result is described in the following reply.

Thanks,
Gao Xiang

include/linux/bit_spinlock.h | 23 ++++++++++-------------
1 file changed, 10 insertions(+), 13 deletions(-)

diff --git a/include/linux/bit_spinlock.h b/include/linux/bit_spinlock.h
index bbc4730a6505..d5f922b5ffd9 100644
--- a/include/linux/bit_spinlock.h
+++ b/include/linux/bit_spinlock.h
@@ -15,22 +15,19 @@
*/
static inline void bit_spin_lock(int bitnum, unsigned long *addr)
{
- /*
- * Assuming the lock is uncontended, this never enters
- * the body of the outer loop. If it is contended, then
- * within the inner loop a non-atomic test is used to
- * busywait with less bus contention for a good time to
- * attempt to acquire the lock bit.
- */
- preempt_disable();
#if defined(CONFIG_SMP) || defined(CONFIG_DEBUG_SPINLOCK)
- while (unlikely(test_and_set_bit_lock(bitnum, addr))) {
- preempt_enable();
- do {
- cpu_relax();
- } while (test_bit(bitnum, addr));
+ const unsigned int bitshift = bitnum & (BITS_PER_LONG - 1);
+
+ while (1) {
+ smp_cond_load_relaxed(&addr[BIT_WORD(bitnum)],
+ !((VAL >> bitshift) & 1));
preempt_disable();
+ if (!test_and_set_bit_lock(bitnum, addr))
+ break;
+ preempt_enable();
}
+#else
+ preempt_disable();
#endif
__acquire(bitlock);
}
--
2.17.1
\
 
 \ /
  Last update: 2018-10-30 06:51    [W:0.133 / U:0.068 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site