lkml.org 
[lkml]   [2018]   [Jan]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v2] drm/stm: drv: Improve data transfers
Date
Hi Benjamin,

On Tuesday, 30 January 2018 17:08:48 EET Benjamin Gaignard wrote:
> 2018-01-30 15:58 GMT+01:00 Laurent Pinchart:
> > On Tuesday, 30 January 2018 12:42:00 EET Philippe Cornu wrote:
> >> To optimize data transfers, align pitch on 128 bytes & height
> >> on 4 bytes. This optimization is not applicable on hw without MMU.
> >>
> >> Signed-off-by: Yannick Fertre <yannick.fertre@st.com>
> >> Signed-off-by: Vincent Abriou <vincent.abriou@st.com>
> >> Signed-off-by: Philippe Cornu <philippe.cornu@st.com>
> >> ---
> >> Changes in v2: Rename stm_dumb_create() to stm_gem_cma_dumb_create() and
> >>
> >> move CONFIG_MMU inside the function following comments from Benjamin
> >> Gaignard.
> >>
> >> drivers/gpu/drm/stm/drv.c | 20 +++++++++++++++++++-
> >> 1 file changed, 19 insertions(+), 1 deletion(-)
> >>
> >> diff --git a/drivers/gpu/drm/stm/drv.c b/drivers/gpu/drm/stm/drv.c
> >> index 8fe954c27fba..8bc7e8418b8d 100644
> >> --- a/drivers/gpu/drm/stm/drv.c
> >> +++ b/drivers/gpu/drm/stm/drv.c
> >> @@ -31,6 +31,24 @@ static const struct drm_mode_config_funcs
> >> drv_mode_config_funcs = { .atomic_commit = drm_atomic_helper_commit,
> >>
> >> };
> >>
> >> +static int stm_gem_cma_dumb_create(struct drm_file *file,
> >> + struct drm_device *dev,
> >> + struct drm_mode_create_dumb *args)
> >> +{
> >> +#ifdef CONFIG_MMU
> >> + unsigned int min_pitch = DIV_ROUND_UP(args->width * args->bpp, 8);
> >> +
> >> + /*
> >> + * in order to optimize data transfer, pitch is aligned on
> >> + * 128 bytes, height is aligned on 4 bytes
> >> + */
> >> + args->pitch = roundup(min_pitch, 128);
> >> + args->height = roundup(args->height, 4);
> >> +#endif
> >> +
> >> + return drm_gem_cma_dumb_create_internal(file, dev, args);
> >
> > In the !CONFIG_MMU case you now bypass the pitch and size calculations
> > performed by drm_gem_cma_dumb_create(), allowing userspace to allocate
> > arbitrarily large buffers. Is that intentional ?
>
> My bad, I will send a fix

Thank you.

> >> +}
> >> +
> >>
> >> DEFINE_DRM_GEM_CMA_FOPS(drv_driver_fops);
> >>
> >> static struct drm_driver drv_driver = {
> >>
> >> @@ -44,7 +62,7 @@ static struct drm_driver drv_driver = {
> >>
> >> .minor = 0,
> >> .patchlevel = 0,
> >> .fops = &drv_driver_fops,
> >>
> >> - .dumb_create = drm_gem_cma_dumb_create,
> >> + .dumb_create = stm_gem_cma_dumb_create,
> >>
> >> .prime_handle_to_fd = drm_gem_prime_handle_to_fd,
> >> .prime_fd_to_handle = drm_gem_prime_fd_to_handle,
> >> .gem_free_object_unlocked = drm_gem_cma_free_object,

--
Regards,

Laurent Pinchart

\
 
 \ /
  Last update: 2018-01-30 16:11    [W:0.064 / U:0.132 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site