lkml.org 
[lkml]   [2018]   [Jan]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v6 16/24] mm: Protect mm_rb tree with a rwlock
On Fri, Jan 12, 2018 at 06:26:00PM +0100, Laurent Dufour wrote:
> -static void __vma_rb_erase(struct vm_area_struct *vma, struct rb_root *root)
> +static void __vma_rb_erase(struct vm_area_struct *vma, struct mm_struct *mm)
> {
> + struct rb_root *root = &mm->mm_rb;
> /*
> * Note rb_erase_augmented is a fairly large inline function,
> * so make sure we instantiate it only once with our desired
> * augmented rbtree callbacks.
> */
> +#ifdef CONFIG_SPF
> + write_lock(&mm->mm_rb_lock);
> +#endif
> rb_erase_augmented(&vma->vm_rb, root, &vma_gap_callbacks);
> +#ifdef CONFIG_SPF
> + write_unlock(&mm->mm_rb_lock); /* wmb */
> +#endif

I can't say I love this. Have you considered:

#ifdef CONFIG_SPF
#define vma_rb_write_lock(mm) write_lock(&mm->mm_rb_lock)
#define vma_rb_write_unlock(mm) write_unlock(&mm->mm_rb_lock)
#else
#define vma_rb_write_lock(mm) do { } while (0)
#define vma_rb_write_unlock(mm) do { } while (0)
#endif

Also, SPF is kind of uninformative. CONFIG_MM_SPF might be better?
Or perhaps even CONFIG_SPECULATIVE_PAGE_FAULT, just to make it really
painful to do these one-liner ifdefs that make the code so hard to read.

\
 
 \ /
  Last update: 2018-01-14 23:26    [W:1.898 / U:0.060 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site