lkml.org 
[lkml]   [2017]   [Sep]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 4/4] pid: Remove pidhash
From
Date
On Mon, 2017-09-25 at 08:56 -0400, Gargi Sharma wrote:
> pidhash is no longer required as all the information
> can be looked up from idr tree. Also, nr_hashed represented
> the number of pids that had been hashed. Since, nr_hashed is
> no longer relevant, it has been renamed to pid_allocated.
>
> Signed-off-by: Gargi Sharma <gs051095@gmail.com>

> @@ -66,7 +59,7 @@ int pid_max_max = PID_MAX_LIMIT;
>  struct pid_namespace init_pid_ns = {
>   .kref = KREF_INIT(2),
>   .idr = IDR_INIT,
> - .nr_hashed = PIDNS_HASH_ADDING,
> + .pid_allocated = PIDNS_HASH_ADDING,
>   .level = 0,
>   .child_reaper = &init_task,
>   .user_ns = &init_user_ns,
>

Should PIDNS_HASH_ADDING be renamed too, now that the pidhash is
gone?

Not that I have any ideas for a better name. This patch looks good
to me. Feel free to add this line the next time you submit it:

Reviewed-by: Rik van Riel <riel@redhat.com>

--
All Rights Reversed.[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2017-09-25 15:49    [W:0.078 / U:0.368 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site