lkml.org 
[lkml]   [2017]   [Mar]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [Outreachy kernel] [PATCH 1/4] iio: common: st_sensors: Replace ternary operator with min macro
On Wed, Mar 29, 2017 at 3:33 PM, simran singhal
<singhalsimran0@gmail.com> wrote:
> Use macro min() to get the minimum of two values for brevity and
> readability.
>
> Signed-off-by: simran singhal <singhalsimran0@gmail.com>
> ---
> drivers/iio/common/st_sensors/st_sensors_i2c.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/iio/common/st_sensors/st_sensors_i2c.c b/drivers/iio/common/st_sensors/st_sensors_i2c.c
> index c83df4d..7a68fdd 100644
> --- a/drivers/iio/common/st_sensors/st_sensors_i2c.c
> +++ b/drivers/iio/common/st_sensors/st_sensors_i2c.c
> @@ -39,7 +39,7 @@ static int st_sensors_i2c_read_byte(struct st_sensor_transfer_buffer *tb,
> *res_byte = err & 0xff;
>
> st_accel_i2c_read_byte_error:
> - return err < 0 ? err : 0;
> + return min(err, 0);
> }

Appreciate the brevity but this certainly doesn't make code
easier to read.

In linux kernel err < 0 signifies an error and be replacing
comparison < 0 with min() we some hide the meaning of this.

thanks,
Daniel.

\
 
 \ /
  Last update: 2017-03-29 18:17    [W:0.080 / U:0.428 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site