lkml.org 
[lkml]   [2017]   [Mar]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 0/4] uapi glibc compat: fix musl libc compatibility
Date
From
On 2017-03-12 23:00, Hauke Mehrtens wrote:
> The code from libc-compat.h depends on some glibc specific defines and
> causes compile problems with the musl libc. These patches remove some
> of the glibc dependencies. With these patches the LEDE (OpenWrt) base
> user space applications can be build with unmodified kernel headers and
> musl libc.
>
> This was compile tested with the user space from LEDE (OpenWrt) with
> musl 1.1.16, glibc 2.25 and uClibc-ng 1.0.22.
>
> David Heidelberger (1):
> uapi/if_ether.h: prevent redefinition of struct ethhdr
>
> Hauke Mehrtens (3):
> uapi glibc compat: add libc compat code when not build for kernel
> uapi glibc compat: fix build if libc defines IFF_ECHO
> uapi glibc compat: Do not check for __USE_MISC
>
> include/uapi/linux/if_ether.h | 3 +++
> include/uapi/linux/libc-compat.h | 25 +++++++++++++++++++------
> 2 files changed, 22 insertions(+), 6 deletions(-)

Did I send this to the correct maintainer? I am unsure through which
maintainer this should go. I saw that some patches for the libc-compat.h
file went trough David Miller, so I tried the same.

Hauke

\
 
 \ /
  Last update: 2017-03-28 14:02    [W:0.155 / U:0.208 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site