lkml.org 
[lkml]   [2017]   [Oct]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH] net: xfrm_user: use BUG_ON instead of if condition followed by BUG
From
From: Herbert Xu <herbert@gondor.apana.org.au>
Date: Wed, 25 Oct 2017 12:05:41 +0800

> On Tue, Oct 24, 2017 at 05:48:42PM +0900, David Miller wrote:
>>
>> This discussion has happened before.
>>
>> But I'll explain the conclusion here for your benefit.
>>
>> BUG_ON() is a statement and everything inside of it will
>> always execute.
>>
>> BUG_ON() is always preferred because it allows arch
>> specific code to pass the conditional result properly
>> into inline asm and builtins for optimal code generation.
>
> This is a good point. However, while a little bit more verbose you
> can still achieve the same assembly-level result by something like
>
> int err;
>
> err = <insert real code here>;
> BUG_ON(err);
>
> Having real code in BUG_ON may pose problems to people reading the
> code because some of us tend to ignore code in BUG_ON and similar
> macros such as BUILD_BUG_ON.

I agree that this makes the code easier to read and audit.

\
 
 \ /
  Last update: 2017-10-25 06:22    [W:0.074 / U:0.068 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site