lkml.org 
[lkml]   [2016]   [May]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [GIT PULL] Driver core update for 4.7-rc1
From
On Fri, May 20, 2016 at 8:23 PM, Greg KH <gregkh@linuxfoundation.org> wrote:
>
> William Breathitt Gray (13):
> base: isa: Remove X86_32 dependency
> isa: Decouple X86_32 dependency from the ISA Kconfig option

So I'm going to revert these unless I get

(a) a good reason for them

(b) patches to get rid of the incessant warnings these cause.

Most of the ISA drivers are not 64-bit safe. They give compiler
warnings, and they will definitely simply not work. So just blindly
enabling that shit is not the answer.

We've never needed this before, why do we need it now?

Linus

\
 
 \ /
  Last update: 2016-05-21 07:21    [W:0.078 / U:0.408 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site