lkml.org 
[lkml]   [2016]   [Mar]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v3] rtc: s3c: Don't print an error on probe deferral
From
Date
Hello Krzysztof and Alexandre,

On 03/14/2016 11:58 PM, Javier Martinez Canillas wrote:
> Hello Krzysztof,
>
> On 03/14/2016 11:26 PM, Krzysztof Kozlowski wrote:
>> On 15.03.2016 10:59, Javier Martinez Canillas wrote:
>>>>>
>>>>> if (info->data->needs_src_clk) {
>>>>> info->rtc_src_clk = devm_clk_get(&pdev->dev, "rtc_src");
>>>>> if (IS_ERR(info->rtc_src_clk)) {
>>>>> - dev_err(&pdev->dev,
>>>>> - "failed to find rtc source clock\n");
>>>>> + ret = PTR_ERR(info->rtc_src_clk);
>>>>> + if (ret != -EPROBE_DEFER)
>>>>> + dev_err(&pdev->dev,
>>>>> + "failed to find rtc source clock\n");
>>>>> + else
>>>>> + dev_dbg(&pdev->dev,
>>>>> + "probe deferred due to missing rtc src clk\n");
>>>>> clk_disable_unprepare(info->rtc_clk);
>>>>> - return PTR_ERR(info->rtc_src_clk);
>>>>> + return ret;
>>>>> }
>>>>> clk_prepare_enable(info->rtc_src_clk);
>>>>> }
>>>>>
>>>>
>>>> The error path starts looking complicated. This has now 4 indentation
>>>> levels...
>>>>
>>>
>>> Yeah, I don't think we can get rid of the 4 indentation levels since
>>> the function already has 3 and a check for the errno code is needed.
>>
>> Probably handling of the clocks in the driver could be simplified a
>> little bit (the if(needs_src_clk) appears in few places)... but this is
>> out of scope for this patch.
>>
>
> Agreed, I meant without introducing an unrelated change.
>
>>>
>>>> I agree for removal of error in case of probe deferral because it might
>>>> be misleading but I don't see much benefit of a debug message.
>>>>
>>>
>>> But yes, we can at least get rid of the else statement. I don't have a
>>> strong opinion about the debug information, I left it to avoid someone
>>> to tell me that I was removing a useful log.
>>
>> Although dev_dbg doesn't harm... but isn't driver core printing debug
>> message already?
>>
>
> I don't think it does or at least I didn't find it when looking
> at the devm_clk_get() call chain.
>
>> BR,
>> Krzysztof
>>

Just to make sure that I understood correctly, there's no action I
should take in order for this patch to be picked right? IOW, the
current version is OK?

Best regards,
--
Javier Martinez Canillas
Open Source Group
Samsung Research America

\
 
 \ /
  Last update: 2016-03-18 13:41    [W:0.082 / U:0.988 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site