lkml.org 
[lkml]   [2015]   [Sep]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 1/2] zbud: allow PAGE_SIZE allocations
From
Hi Dan,

On Mon, Sep 21, 2015 at 6:17 PM, Dan Streetman <ddstreet@ieee.org> wrote:
> Please make sure to cc Seth also, he's the owner of zbud.

Sure :)

<snip>
>> @@ -514,8 +552,17 @@ int zbud_reclaim_page(struct zbud_pool *pool, unsigned int retries)
>> return -EINVAL;
>> }
>> for (i = 0; i < retries; i++) {
>> - zhdr = list_tail_entry(&pool->lru, struct zbud_header, lru);
>> - list_del(&zhdr->lru);
>> + page = list_tail_entry(&pool->lru, struct page, lru);
>> + zhdr = page_address(page);
>> + list_del(&page->lru);
>> + /* Uncompressed zbud page? just run eviction and free it */
>> + if (page->flags & PG_uncompressed) {
>> + page->flags &= ~PG_uncompressed;
>> + spin_unlock(&pool->lock);
>> + pool->ops->evict(pool, encode_handle(zhdr, FULL));
>> + __free_page(page);
>> + return 0;
>
> again, don't be redundant. change the function to handle full-sized
> pages, don't repeat the function in an if() block for a special case.

Well, this case is a little tricky. How to process a zbud page in
zbud_reclaim_page() is defined basing on the assumption there is a
zhdr at the beginning of the page. What can be done here IMV is either
of the following:
* add a constant magic number to zhdr and check for it, if the check
fails, it is a type FULL page
* add a CRC field to zhdr, if CRC check over assumed zhdr fails, it
is a type FULL page
* use a field from struct page to indicate its type

The last option still looks better to me.

~vitaly


\
 
 \ /
  Last update: 2015-09-22 12:41    [W:0.036 / U:0.352 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site