lkml.org 
[lkml]   [2015]   [Sep]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8()
On 2015/9/12 6:47, Andrew Morton wrote:

> On Fri, 11 Sep 2015 10:02:29 +0800 Xishi Qiu <qiuxishi@huawei.com> wrote:
>
>> Use IS_ALIGNED() to determine whether the shadow span two bytes.
>> It generates less code and more readable.
>>
>
> Please cc Andrey Ryabinin on kasan patches.

Sorry, my mistake.

>
>> --- a/mm/kasan/kasan.c
>> +++ b/mm/kasan/kasan.c
>> @@ -120,7 +120,7 @@ static __always_inline bool memory_is_poisoned_8(unsigned long addr)
>> if (memory_is_poisoned_1(addr + 7))
>> return true;
>>
>> - if (likely(((addr + 7) & KASAN_SHADOW_MASK) >= 7))
>> + if (likely(IS_ALIGNED(addr, 8)))
>> return false;
>
> Wouldn't IS_ALIGNED(addr, KASAN_SHADOW_SCALE_SIZE) be more appropriate?
>

OK, I'll send V2.

> But I'm not really sure what the original code is trying to do.
>
> if ((addr + 7) & 7) >= 7)
>
> can only evaluate true if ((addr + 7) & 7) equals 7, so the ">=" could
> be "==".
>

I think it should be "==", the value will not "> 7"

> I think. The code looks a bit weird. A code comment would help.
>
> And how come memory_is_poisoned_16() does IS_ALIGNED(addr, 8)? Should
> it be 16?

No, it is to determine whether the shadow span two bytes(8 bytes, not 16).

Thanks,
Xishi Qiu

>
>
> .
>





\
 
 \ /
  Last update: 2015-09-14 03:41    [W:0.049 / U:2.412 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site