lkml.org 
[lkml]   [2015]   [Aug]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 4/7] x86/vm86: Move vm86 fields out of thread_struct

* Brian Gerst <brgerst@gmail.com> wrote:

> > Btw., the variable names here are crazy. I had to look twice to realize that
> > we have 'v86' and 'vm86' which are two different things.
> >
> > Also, vm86plus_struct variables and fields are named wildly inconsistently:
> > sometimes it's 'vm86.vm86_info', sometimes it's 'v86', sometimes 'user'. Ugh.
> >
> > Other fields have naming inconsistencies as well: for example we have
> > thread.vm86->vm86plus.vm86dbg_active. 'vm86' is repeated _three_ times in that
> > name, for no good reason.
> >
> > So please clean up the naming to make this all easier to read. Only the
> > highest level field should have 'vm86' in it - all subsequent fields will
> > inherit that name one way or another.
>
> Some of these field names are visible to userspace and can't change.

That's a misconception: bits in the uapi headers can be renamed just fine.

The kernel ABI is that _semantics_ that user-space code relies on must not change.

Cleaning up field names is absolutely legit to do, and we've done it numerous
times in the past. Especially where they are so confusing and inconsistent as in
the vm86 code.

Thanks,

Ingo


\
 
 \ /
  Last update: 2015-08-05 11:01    [W:0.069 / U:0.032 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site