lkml.org 
[lkml]   [2015]   [Aug]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH RFC V3 2/2] net: Optimize snmp stat aggregation by walking all the percpu data at once
On 08/29/2015 08:51 PM, Joe Perches wrote:
> On Sat, 2015-08-29 at 07:32 -0700, Eric Dumazet wrote:
>> On Sat, 2015-08-29 at 14:37 +0530, Raghavendra K T wrote:
>>
>>>
>>> static inline void __snmp6_fill_stats64(u64 *stats, void __percpu *mib,
>>> - int items, int bytes, size_t syncpoff)
>>> + int items, int bytes, size_t syncpoff)
>>> {
>>> - int i;
>>> + int i, c;
>>> int pad = bytes - sizeof(u64) * items;
>>> + u64 buff[items];
>>> +
>>
>> One last comment : using variable length arrays is confusing for the
>> reader, and sparse as well.
>>
>> $ make C=2 net/ipv6/addrconf.o
>> ...
>> CHECK net/ipv6/addrconf.c
>> net/ipv6/addrconf.c:4733:18: warning: Variable length array is used.
>> net/ipv6/addrconf.c:4737:25: error: cannot size expression
>>
>>
>> I suggest you remove 'items' parameter and replace it by
>> IPSTATS_MIB_MAX, as __snmp6_fill_stats64() is called exactly once.
>
> If you respin, I suggest:
>
> o remove "items" from the __snmp6_fill_stats64 arguments
> and use IPSTATS_MIB_MAX in the function instead

Yes, as also suggested by Eric.

> o add braces around the for_each_possible_cpu loop
>
> for_each_possible_cpu(c) {
> for (i = 1; i < items; i++)
> buff[i] += snmp_get_cpu_field64(mib, c, i, syncpoff);
> }
>

Sure. It makes it more readable.
will respin V4 with these changes (+ memset 0 for pad which I realized).





\
 
 \ /
  Last update: 2015-08-29 19:41    [W:0.056 / U:1.488 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site