lkml.org 
[lkml]   [2015]   [Jul]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] defines modified to match the 80-char rule
From
Date
On Fri, 2015-07-03 at 12:58 +0200, Krzysztof Hałasa wrote:
> Joe Perches <joe@perches.com> writes:
>
> > -#define LCONSOLE(mask, format, ...) CDEBUG(D_CONSOLE | (mask), format, ## __VA_ARGS__)
> > -#define LCONSOLE_INFO(format, ...) CDEBUG_LIMIT(D_CONSOLE, format, ## __VA_ARGS__)
> > -#define LCONSOLE_WARN(format, ...) CDEBUG_LIMIT(D_CONSOLE | D_WARNING, format, ## __VA_ARGS__)
> > -#define LCONSOLE_ERROR_MSG(errnum, format, ...) CDEBUG_LIMIT(D_CONSOLE | D_ERROR, \
> > - "%x-%x: " format, errnum, LERRCHKSUM(errnum), ## __VA_ARGS__)
> > -#define LCONSOLE_ERROR(format, ...) LCONSOLE_ERROR_MSG(0x00, format, ## __VA_ARGS__)
> > +#define LCONSOLE(mask, fmt, ...) \
> > + CDEBUG(D_CONSOLE | (mask), fmt, ##__VA_ARGS__)
> > +#define LCONSOLE_INFO(fmt, ...) \
> > + CDEBUG_LIMIT(D_CONSOLE, fmt, ##__VA_ARGS__)
> > +#define LCONSOLE_WARN(fmt, ...) \
> > + CDEBUG_LIMIT(D_CONSOLE | D_WARNING, fmt, ##__VA_ARGS__)
> > +#define LCONSOLE_ERROR_MSG(errnum, fmt, ...) \
> > + CDEBUG_LIMIT(D_CONSOLE | D_ERROR, "%x-%x: " fmt, \
> > + errnum, LERRCHKSUM(errnum), ##__VA_ARGS__)
>
> I don't find it better, actually I think it's much harder to read.
>
> Maybe that's just me.
>
> Call me extremist, but I think I could even like the following :-)
>
> #define CWARN(format, ...) CDEBUG_LIMIT(D_WARNING, format, ## __VA_ARGS__)
> #define CERROR(format, ...) CDEBUG_LIMIT(D_ERROR, format, ## __VA_ARGS__)
> #define CNETERR(format, ...) CDEBUG_LIMIT(D_NETERROR, format, ## __VA_ARGS__)
> #define CEMERG(format, ...) CDEBUG_LIMIT(D_EMERG, format, ## __VA_ARGS__)

Nah, you're not an extremist, you're just preferring narrowly
localized readability over global consistency.

That's fine and all, until you come up to LCONSOLE_ERROR_MSG
type use which blows the nice old formatting up.

So what I suggested is just a simple consistency thing.




\
 
 \ /
  Last update: 2015-07-03 18:21    [W:0.077 / U:0.120 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site