[lkml]   [2015]   [Jul]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] iio: Fix iio_validate_scan_mask_oneshot function name typo
On 07/19/2015 11:49 AM, Jonathan Cameron wrote:
> On 18/07/15 15:31, Cristina Opriceana wrote:
>> Rename function to iio_validate_scan_mask_oneshot() since it's used to
>> validate that only one channel is selected.
>> Signed-off-by: Cristina Opriceana <>
> I'm sure Lars (who I think named it?) will come back with a fuller response, but
> I believe the naming (if not necessarily clear!) was deliberate.
> one hot - as in only one channel is enabled at a time.
> oneshot - only a single reading of all channels is taken
> (like a one shot interrupt).

Yes. See


 \ /
  Last update: 2015-07-19 12:21    [W:0.032 / U:0.176 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site