[lkml]   [2015]   [Jun]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] x86/asm/entry/32: Rename labels in INT 0x80 code path
On Mon, Jun 8, 2015 at 1:35 AM, Ingo Molnar <> wrote:
> * Linus Torvalds <> wrote:
>> On Jun 7, 2015 11:42 AM, "Denys Vlasenko" <> wrote:
>> >
>> > Rename it to ia32_int80_target.
>> Btw, could we arrive to get rid of the idiotic "ia32" naming too? It's wrong,
>> and it harkens back to the days when intel thought itanium makes sense and
>> wanted to talk about "intel architecture".
> Absolutely, I've been slowly eliminating uses of it - that naming is very
> annoying.
> Another thing I'm doing is to slowly remove references to 'emulation' - we don't
> emulate 32-bit in any way, we implement various 32-bit syscall ABIs (old a new)
> natively.
> I'd like to remove CONFIG_IA32_EMULATION from the .config as well - it offers
> nothing real over CONFIG_COMPAT.

A few months ago I started working on a set of patches to decouple the
X32 support from the 32-bit compat support. There is actually quite a
bit of non-shared code between the two, mainly signal handling and
syscall entries. The code used by both should be CONFIG_COMPAT, but
separate config defines should be kept for the non-shared code. That
would allow X32 support without dragging in all of the 32-bit compat
support. I never finished it because I couldn't find a current
distribution that supported X32 out of the box to test with.

I agree on dropping the word emulation though, since the hardware
provides a full 32-bit environment. I suggest CONFIG_X86_32_COMPAT
(or CONFIG_COMPAT_X86_32) as a new name.

Brian Gerst

 \ /
  Last update: 2015-06-08 17:21    [W:0.061 / U:0.040 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site