lkml.org 
[lkml]   [2015]   [Jun]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC PATCH] Rename ia32entry.S to entry_64_compat_32.S

* Andy Lutomirski <luto@amacapital.net> wrote:

> On Fri, Jun 5, 2015 at 2:09 PM, H. Peter Anvin <hpa@zytor.com> wrote:
> > Call it sys if it is now only the system call entry points. Agreed with _64_compat too.
> >
> > Breaking up these snarls of spaghetti assembly will be a blessing.
>
> I'm not too picky about what we call it or whether we merge it with entry_64.S.
> *However*, I think the file name should end in _64.S. The whole arch/x86 tree is
> arranged such that files that end in _64.S or _64.c are build for 64-bit kernels
> and not for 32-bit kernels. I see no reason to deviate from that.
>
> FWIW, I'm eventually planning to completely rewrite the compat entry points to
> use the new (RFC patches coming in a week or two I hope!) C exit code with
> opportunistic sysretl at the end. I'm guessing the result will be about half
> the size of the current code, and it'll be comprehensible to mere mortals.

Ok, so I think the best is if I leave it alone for now: I've renamed it to
entry_64_compat.S as per Boris's and hpa's suggestion, but won't merge it into
entry_64.S (yet), let's see how your C conversion works out!

Thanks,

Ingo


\
 
 \ /
  Last update: 2015-06-07 15:21    [W:0.038 / U:0.888 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site